Support » Plugin: Magic Fields 2 » [Plugin: Magic Fields 2] Visual editor not displaying for multiline fields

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Gnuget

    (@gnuget)

    I think to this was fixed into the development version.

    want you help us to test it?

    https://github.com/magic-fields-team/Magic-Fields-2

    We will release a fixed version for wp 3.3 soon

    Hi, I appreciate the response. Due to lack of time I actually ended up using another plugin but ran into a similar plugin with that too. I appears that the WYSIWYG editor would only appear on the custom field visual editor if the ‘Visual’ tab on the main content was selected (as apposed to the ‘HTML’ tab).

    Not sure if this has anything to do with the issue I experienced with MF2 but I thought it was worth a mention as it has me scratching my head for a while.

    All the best.

    I have installed the development version and there are still no rich text editor tools visible. In console I see several errors about not being able to find Tiny MCE. Specifically it is getting a 404 looking for this:

    http://mysite.com/wp-includes/js/tinymce/themes/simple/editor_template.js?ver=345-20111127

    There is also an “uncaught referenceerror” for the method “switchEditors” not being defined. That method is called on line 44 of multiline_field.js.

    Since it was looking for the “simple” theme, which is apparently not present in WordPress 3.3.1, I downloaded it from TinyMCE, stuck it in the expected path and now it works.

    It is only the simple theme so now I am going to look at how to set it to use the Advanced theme but this will at least get things working for anyone needing it.

    Let me add to this. I know there’s been no posts in the past 3 months but I just started using MF2 and I’m experiencing the exact same issues. morehawes is correct. If you have the main visual editor on for the main content, you get the visual editor everywhere else. Turn it off, and it’s all gone everywhere. Very frustrating although I like a lot of the changes in the new version.

    I’ve got the same problem. Any chance someone fixed it yet?
    Btw, great plugin! made my life easier! Thanks

    Mariachiara Pezzotti

    (@mariachiara-pezzotti)

    hello I installed this version.
    https://github.com/magic-fields-team/Magic-Fields-2
    Now I see the visual editor, it works! thanks a lot!
    It ‘s all ok except the key “link” in tiny editor: does not work (no errors or warnings in firebug console). What can I do?

    Thankyou very much.

    Hi there, we’re using Magic Fields 2,0,1
    The visual editor appears partially.
    2 tabs vial/html and add media icon.
    Other icons don’t appear.

    Any idea ?
    Thanks

    knijia

    (@knijia)

    Hi, i’ve had the same issue with MF2 and TinyMCE. I resolved it in deactivating the tinyMCE plugin, then in MF2 i clicked on “edit post type” on my post type and save the post type (without changing anything), diconnected from the WP admin and reconnecting, reactivating the TinyMCE plugin and the visual editor reappaeared … hope it would help someone.

    inTOWN

    (@intown)

    Same problem here: only 2 tabs + media button. Deactivating the tinyMCE plugin didn’t help since I didn’t have that plugin in the first place.

    New wordpress release, same problem again. (no visual editor)

    I just solved this issue by editing the Post Type and checking, Supports: “Editor”, and Saving it.

    Now, I just need to figure out how to get rid of the Editor since I don’t need it! I may just disable it with CSS.

    Any advice?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: Magic Fields 2] Visual editor not displaying for multiline fields’ is closed to new replies.