Support » Plugin: WP Minify » Plugin looking up for old .js cached files

  • Hi,

    I had this problem once before, when I moved my website from a web hosting to another.
    Here it is. Wp-minify makes my web page referring to a cache file for javascripts like this one : wp-content/plugins/wp-minify/cache/4523ae88ee8d65f8e03dea95496eb5c1.js

    But this file no longer exists. This obiously break all my js by the way.

    I have tried to uninstall/reinstall it, but seems like some data are kept even in this case. For example, even the caching expire timing was back to what I set it (86400 seconds) after a reinstall.

    So my guess is this is somewhere in the database. But couldn’t find anything relevant there.

    How can I manage to deal with this ?

    I have to add that only happens with JS minified file, never with CSS.

    Last time, I tried to install Better WP Minify, which was triggering even more problems. Went back to test WP minify further.. and it was working again ! Never found out what helped me.

    I hope the developer will have a look at all those threads and do some debugging sometimes, because his plugin is the most efficient one out there (W3 Total Cache is supposed to do it too, but it hasn’t been updated in a while and triggers also some problems on my theme)

    Anyway, your thoughts on this are very welcome !


Viewing 5 replies - 1 through 5 (of 5 total)
  • Yup i noticed that problem too which is why i rewrote some of this plugins internal code.

    I assume yyour html page has a cache time (or is a cached file made by a quick cache type plugin). When that time expires it should go making updates, triggering this plugin to reevaluate its minified .js file to a new name (if necessary).

    I noticed internally his method for naming these files (md5) is a bit improper and under conditions can cause problems. I rewrote my forked version of this plugin to resolve most of his problems, and by extension my problems.

    Yep, it finally worked back as normal… and I couldn’t find the reason. All what was in the database was the settings of the plugin (even after uninstalling it…)

    I was also using Hyper Cache, but even deactivating it wasn’t enough. So maybe it’s related as you said to some cache time on which WP Minify was relying. I use Hyper Cache, but clearing cache or disabling it wasn’t enough. Just “waiting” solved it.

    Unfortunately, I am not good enough in coding to rewrite this plugin. I tried to understand some of it, but was quickly lost.
    Would you mind sharing yours ? I can be reached by email at “eddy1103” on gmail if you are okay.

    And I still hope the author will do some update on this plugin. I couldn’t find a better one, even with its “quirks” 🙂

    Okay, so it was just my browser cache (I am using Chrome and Firefox at the same time for other reasons…) that tricked me. It’s still looking for this file that doesn’t exist. :/

    Since I am experiencing this problem and couldn’t find a fix, I created some test pages to maybe found out what was going on.

    • First, the “normal” home page :
      Nothing to say, it works.
    • Now, second page :
      This one uses minified CSS and JS code as below :

      <link rel='stylesheet' href='' type='text/css' media='screen' />
      <script type="text/javascript" src=",wp-content/themes/modularity_original/includes/js/nav/superfish.js,wp-content/themes/modularity_original/includes/js/nav/supersubs.js,wp-content/themes/modularity_original/includes/js/search.js,wp-includes/js/swfobject.js,wp-content/themes/modularity_original/includes/js/jquery.cycle.js,wp-includes/js/jquery/ui/jquery.ui.core.min.js,wp-includes/js/jquery/ui/jquery.ui.widget.min.js,wp-includes/js/jquery/ui/jquery.ui.mouse.min.js,wp-includes/js/jquery/ui/jquery.ui.slider.min.js,wp-content/themes/modularity_original/includes/js/slider/slider.js"></script>

      Here I am using the “pretty” url for CSS but I could have used the not so pretty one, it is working in both cases so I didn’t bother.

      This page produce a strange error, an unexpected token “<” at line one… even though it is the same source code as test1. Plus a jQuery is not defined line 626 (again, same source code…)
      And finally, all the JS that are in the footer produce each a jQuery is not defined.

      Does anyone see any reason for all those errors ?

    • Third and last test page :

      This time I am using the “pretty url” and get ONE error only :

      Uncaught ReferenceError: handleSliderChange is not defined test3.html:650
      (anonymous function) test3.html:650
      l     20071a0aed9fd02fec240eee0849043a.js:2
      c.fireWith    20071a0aed9fd02fec240eee0849043a.js:2
      v.extend.ready    20071a0aed9fd02fec240eee0849043a.js:2
      A          20071a0aed9fd02fec240eee0849043a.js:2

      I don’t understand this one…. I had a look at this handleSliderChange, but couldn’t understand why it’s not defined.

    So here I am… all I can do using the plugin is minify CSS. I treid Better WP Minify, but it triggers some other errors too. One of is the “unexpected token <“, but if my source code was wrong, why would it produce an error ONLY when I minify JS ?

    Any help will be much appreciated !


    Had an idea. In fact I tested my website on another server and it worked perfectly.
    But this other server is in Europe (where I live) when my actual website is is hosted in US. So this made me think they may be some time shift delay occuring here.

    I place a SetEnv SetEnv TZ Europe/Paris in .htaccess. If I call the date/time with in a php file, it’s getting the right time in which I am. But I noticed the files where time stamped (for their creation date) on the US time zone (8 hours of delay in fact)

    I wasn’t able to find what function was dealing with this. But since this happens only with JS pretty url files, I thought maybe it wasn’t coded the same way than the CSS pretty url files ?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Plugin looking up for old .js cached files’ is closed to new replies.