WordPress.org

Support

Support » Plugins and Hacks » Login LockDown » [Plugin: Login LockDown] Plugin using deprecated argument

[Plugin: Login LockDown] Plugin using deprecated argument

Viewing 7 replies - 1 through 7 (of 7 total)
  • I am too getting this message in debug mode

    Hello,

    This is caused by the use of user levels which were deprecated a while back and replaced with the new roles and capabilities.

    This plugin is still using the user levels when creating their options page. You can view the code below of where they create this on line 297 or so.

    add_options_page('Login LockDown', 'Login LockDown', 9, basename(__FILE__), 'print_loginlockdownAdminPage');

    The 9 is the user level call that is throwing the error message. This code above should be replace with the following instead:

    add_options_page('Login LockDown', 'Login LockDown', 'edit_users', basename(__FILE__), 'print_loginlockdownAdminPage');

    This allows anyone with the capability of editing users to view the Login Lockdown options page (this is usually only users with the Administrator role.)

    I have applied this to my site and it seems to have removed the error. Let me know if you have any problems implementing this.

    Yeah, I know I can manually fix it, but I was hoping the author would so that the changes wouldn’t get overwritten with new versions.

    Yeah I tried emailing the author of the plugin to see if he would like some help with developing things so fixes like this could be implemented but I haven’t heard back yet.

    I guess the good news though is that any changes you do make won’t be overwritten until he does update the plugin. I will wait to hear back from him for a while and if I don’t hear anything I might fork the project and oversee it’s future development.

    That’d be cool, let me know if you fork it. I also might switch to using the Login Lock plugin, but I don’t think they mask login error messages like Login Lockdown does.

    There’s a new plugin that I tried out called Login Security Solution and I’m really happy with it. I think the code higher quality, and it’s more comprehensive than the other plugins out there. I’ve talked to the developer too, and he’s been very responsive to feedback.

    Came here to report the same issue! What’s even more surprising is that this was deprecated at 2.0!

    Argument in add_options_page()
    Used in wp-content/plugins/login-lockdown/loginlockdown.php on line 299.

    Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. Deprecated in version 2.0.

    Ian, that new plugin looks great! Thanks for sharing.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Login LockDown] Plugin using deprecated argument’ is closed to new replies.
Skip to toolbar