Support » Plugin: iThemes Security (formerly Better WP Security) » Plugin Locks Up at Setup

  • Resolved Susan Warren

    (@susan-warren)


    I installed the latest iThemes Security on a new site and when I go to set up the plugin I’m presented with an “Important First Steps” popup that locks up the admin area so that I can’t click on the popup to make a choice, I can’t dismiss the popup, and I can’t click the X to close it. Further, I can’t get back to the admin panel or even log out. The only way I can get out of it is to close the browser tab.

    At first I thought it might have been a browser problem (Firefox) so I tried the same process in Chrome and got the same results.

    So I logged back into the site and uninstalled and deleted iThemes Security, thinking that it might be a problem with the newest version. With that in mind I went to another site that’s running an earlier version the plugin (4.3.11) and zipped up the plugin, downloaded it, uploaded it to the new site, unzipped it, went back into the new site admin panel– and got the same results. The “Important First Steps” popup locks up everything, even with the old plugin.

    Now I know that the old version installed properly on the other site — I did it myself — so why is it throwing the problems on the new site? Both sites are on the same host so I know it’s not something like a php issue. Any ideas or suggestions would be greatly appreciated.

    https://wordpress.org/plugins/better-wp-security/

Viewing 5 replies - 1 through 5 (of 5 total)
  • An update. I decided to update the plugin to the latest version. Still no change, but I did come across this: I noticed that the “backup your site” “make a backup” button had a blue outline, so even though I couldn’t click on it and get any action, I could hit the “enter” key and get the backup to start running. Except that almost immediately I got an error message saying “Whoops. Something went wrong. Check the backup page or contact support.” I couldn’t check the backup page because every time I went into the plugin I would get the popup window that locked up everything. I can make database and site backups via “Backwpup” which I installed after the iThemes backup error in order to test the backup process, so the problem seems to be directly iThemes Security related.

    Again, any help, ideas, or suggestions would be appreciated.

    Probably a .css or javascript\JQuery conflict with another plugin (or the active theme).

    Resolved a similar issue in this topic:

    https://wordpress.org/support/topic/important-first-steps-screen-freezed

    Use the FireFox build in Inspector (or a browser addon like Firebug) to check the css properties of the First Important Steps modal screen.
    You’ll find the modal window html element at the bottom of the html page.

    dwinden

    Thanks! That fixed it. I found the offending .ui-front z-index and commented it out in Firebug, and the First Important Steps screen became active. I dismissed the screen and then went into the settings panel and set things up the way I wanted with no problems (the popup screen stayed “dismissed”). After I had done the set up the First Important Steps no longer appeared after I logged out and back in several times just to check.

    So even if there is a theme or plugin ui-front z-index conflict you can still set up iThemes Security this way — and then hopefully be able to trace down the conflict at your leisure.

    Nice, good thinking.

    Should you ever wish to go back into the First Important Steps screen simply click on the Show Intro link in the right upper corner of the iTSec plugin Dashboard screen (and don’t forget to temporarily disable the ui-front z-index css property).

    As the issue seems to be resolved please mark this topic as ‘resolved’.

    dwinden

    Marked as resolved!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Plugin Locks Up at Setup’ is closed to new replies.