Support » Plugin: liveTV Bundle » [Plugin: liveTV Bundle] Warning: file_put_contents

  • Hey there! Thanks a lot for a lovely plug in!

    While using the plug in I get the following warning, right between the IRC channel and the stream list:

    Warning: file_put_contents(/home/mele/domains/ [function.file-put-contents]: failed to open stream: Permission denied in /home/mele/domains/ on line 1007

    Also, while trying to use the widget, it only shows the widget title, and nothing more. Any help will be greatly appriciated! 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author KwarK


    The solution is already in the php alert.

    "...file_put_contents..."......."failed to open stream: Permission denied...."

    php alert is a general server response and not necessary a bug from one plugin but a general php bug for a plugin. “A bug from” and “a bug for” are very different.

    and the problem is …… ???

    * Change your folder permissions on cache folder. test 644 or if 644 don’t work test 755.

    * After, if these changes perms don’t work, verify if you have a htaccess file in your sup-folders where one htaccess protects some folders/sub-folders.

    * After, if all these tests don’t work, its maybe a configuration server. Test to delete index.html in /cache/. If this solution don’t change anything, reset a new empty index.html file in this folder.

    * After the problem comes from other scripts and concerns write process.

    The widget is generated only with the cache system and with the write problem on this folder, the cache is not generated…

    Wow, thanks for an extremely fast reply man!

    I tried the steps you advised. The default permission to the Cache folder was 755. Deleting /Cache/Index.html and recreating it didn’t change much.

    However, I was able to find th .htaccess file, so that’s my only hope for the moment before I go and try deactivating plugins in the site, to see if there’s somekind of conflict between them.

    Hereby is the .htaccess content.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    Thanks so much!

    Plugin Author KwarK


    After updated the pulgin, maybe try to clean your cache system like (wp super cache, wp3 total cache) manually if you use this kind of plugin. I have the same problem when the plugin is installed with wp-super-cache and after an update.

    After one manually cleaning of the cache folder of wp-super-cache, all (re)works correctly for the widget.

    For the file_put_content alert, if you are in localhost (in test environment), try to activate some things for output buffering, etc in php conf

    If you are not in a test environment, I think the problem comes maybe from a configuration server from your hoster.

    I uninstalled wp-super-cache and deleted all of it’s files. Restarted the plugin(s), re-deleted index.html, and tried turning off each of my current plugins, and still, no success.

    Too bad I’m a complete noobie, I don’t even know where to start with checking the server configuration. Do you have any idea what kind of mis-configuration could cause everything to work just fine, but make this rather annoying error to appear?

    Anyhow I still can use the plugin somehow, so thanks a lot for all the work and help dude!

    Plugin Author KwarK


    Add @ the top of your function.php file of your theme


    After, the cache for wp-super-cache is in wp-content/cache/. Delete folder meta, folder supercache and delete all gz file below the htaccess. wp-super-cache recreates automatically these folders, don’t worry.

    If that change changes anything for the php alert, it’s necessary to contact your hoster for this option (output_buffering) if the alert continue.

    Plugin Author KwarK


    I see no other problem like that could act on that.

    Ok, so:

    My theme’s functions.php:

    // Translations can be filed in the /lang/ directory
    load_theme_textdomain( 'themejunkie', TEMPLATEPATH . '/lang' );
    require_once(TEMPLATEPATH . '/includes/sidebar-init.php');
    require_once(TEMPLATEPATH . '/includes/custom-functions.php');
    require_once(TEMPLATEPATH . '/includes/post-thumbnails.php');
    require_once(TEMPLATEPATH . '/includes/theme-comments.php');
    require_once(TEMPLATEPATH . '/includes/theme-options.php');
    require_once(TEMPLATEPATH . '/includes/theme-widgets.php');
    require_once(TEMPLATEPATH . '/functions/theme_functions.php');
    require_once(TEMPLATEPATH . '/functions/admin_functions.php');
    // Uncomment this to test your localization, make sure to enter the right language code.
    // function test_localization( $locale ) {
    // 	return "nl_NL";
    // }
    // add_filter('locale','test_localization');

    I also reinstalled the wp-super-cache, and tried deleting both the meta and supercache folders. I didn’t really understand what to do by “and delete all gz file below the htaccess”.

    I also added a line in wp-config define('WP_CACHE', true);, as adviced by the wp-super-cache plugin.

    Still, no success. I will contact my hoster. Should the option (output_buffering) have a certain value? Or what exactly should I tell my hoster about it?

    Plugin Author KwarK


    Sorry for the delay.

    Tell your hoster if your host spacing can be support file_get_contents / file_put_contents function with its php.ini server configuration and if yes, How to activated it by htaccess / eventually by php file

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: liveTV Bundle] Warning: file_put_contents’ is closed to new replies.