Support » Plugin: Liveblog » [Plugin: Liveblog] Error 404

Viewing 15 replies - 16 through 30 (of 31 total)
  • mazin

    (@mazin)

    Hey guys I solved the problem by just changing my permalink structure option!

    In your Dashboard go to:

    Settings
    Permalinks

    then you will find 6 different options of permalink structures. Try these different structure options one by one until the problem gets solved!

    That’s how I solved mine! good luck!

    Joost

    (@jberculo)

    That’s not so much a solution as a work around. For me, for example, is changing the permalink structure of the site, affecting 10s of thousands of articles, the worst solution possible.

    The problem should be fixed in the code of the plugin, so for now just a subset of WP installs can use this plugin.

    (“Should” like in that it would be the best solution possible. Of course the plugin makers can do whatever they wish, since it is something that they provide free of charge.)

    Plugin Author Nikolay Bachiyski

    (@nbachiyski)

    Hey everybody,

    I tried on several installs with all the permalink structures mentioned above and it always works for me.

    I’d really like to help you. Here are a couple ideas:

    0. Could you disable any caching plugins for a bit?
    1. Could you install the Rewrite Rules Inspector plugin and see if there are any missing rewrite rules? A screenshot of the rules page will be useful.
    2. If anybody is willing to give access to a server with 404-ing liveblog, I’d be happy to have a look.

    Hi, this has happened to me now too. Worked fine when I first installed it yesterday (with permalinks as /%post_id%/%postname%/). Had to sort out another issue so disabled and re-enabled all the plugins and now liveblog only works with the default ?p=xxx permalinks. Very strange. Even on the same test live blog page I created yesterday. I tried installing the Git version zip as well but that didn’t solve the problem. Some strange combination of deactivating Liveblog & W3 Total Cache and reactivating them did. Now seems to be working again with permalinks in place. Weird.

    Plugin Author Nikolay Bachiyski

    (@nbachiyski)

    In general liveblog should be working with W3 Total Cache, but we need to test some more.

    We’ll try to track down the issue for the next version: https://github.com/Automattic/liveblog/issues/91

    It seems there’s a conflict with the plugin Events Manager. Liveblog has served me well several times. I installed EM yesterday and got 404 error codes while trying to live blog The Oscars. It works fine after deactivating EM.

    It really is the most amazing plugin I’ve ever met, but ironically, I can not use it due to the simple fact of using permalinks: http://www.meusite.com/categorias/noticias-locais/

    The worst thing is that I really do not see any interest on the part of the authors to find a solution and gives no clear answers here in support.

    Lords of the plugin authors, at least they can tell us when it will be ready a version that the plugin works properly? If the problem is the fact that it is free, then create a pro version, since that works, we will have great pleasure in buying it.

    Yeah, doesn’t work with permalinks for me either. If I use the default ?p=XX it works fine. I had W3 Total Cache installed before, but it had been deactivated and deleted before I installed Liveblog.

    When I look at the rules with the Rewrite Rules Inspector, I can see that all four rules for liveblog are missing their source. I’ve tried enabling the plugin at the network level and at the individual site level, but neither makes any difference.

    It may help if those experiencing the issue can post details about their server environment. What web server and version are you using (Apache, NginX, etc.). What version of PHP? Perhaps also include your rewrite rules.

    Hej,
    I get the same 404-error with the plugin and my speaking-permalink option, but i don’t use any caching plugin.

    I use a standard apache-webspace. YOu can check my phpconfiguration at http://bolzplatzheld.de/phpinfo.php

    here is my htaccess:
    RedirectMatch 301 ^/([0-9]{4})/([0-9]{2})/(.*)$ http://bolzplatzheld.de/$3
    # BEGIN WordPress

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    if it’s helpful, i can give you an user to liveblog something. please contact me.

    Thanks for your help

    Same here and sometime parsererror 🙁

    Hi, have the same problem since I installed Liveblog yesterday

    /%year%/%category%/%postname%/
    It run as a permalink of substitution

    but something very weird :

    /%category%/%year%/%postname%/
    If you move “category” in the permalink like this, it don’t works anymore…

    I’m hurry that the developers of Liveblog publish an update

    Getting the exact same issue, never happened previously up until recently.

    View post on imgur.com

    Here is the coding of my page template although I do not think there is an issue with it as it hasn’t changed since it worked.

    http://pastebin.com/BevGW5FW

    The error console shows this if its any help.

    “Failed to load resource: the server responded with a status of 404 (Not Found) http://escxtra.com/2013/03/live-blogging-test-2/liveblog/crud&#8221;

    Pedro

    (@petredobrescu)

    Hey all,

    Just ran into the same issue (404’s when posting any update) quite suddenly. As a background:
    – permalinks structure: /%post_id%/%postname%/
    – webserver: nginx
    – custom caching mechanism, tested quite a lot before with Liveblog plugin, all working fine, so I’d exclude caching from the equation.

    All seemed fine up to a point (exactly when the live blogging was supposed to start, obviously) when the 404’s started to appear. After logs of debugging and canceling of all nginx redirects the actual solution that got it going again was:
    – deactivate Liveblog plugin
    – re-activate Liveblog plugin
    – (re)save the permalinks structure

    Before that all links that had either /liveblog/crud or /liveblog/1366743207/1366752213/ (or any other timestamp) at the end were 404’ing no matter what I tried.

    I want to help getting this fixed, let me know if you need further details.

Viewing 15 replies - 16 through 30 (of 31 total)
  • The topic ‘[Plugin: Liveblog] Error 404’ is closed to new replies.