Support » Plugin: Live Blogging » [Plugin: Live Blogging] Comments closed when live?

  • Hi
    When doing a live blogging being linked to twitter is impossible for the readers to comment the post, but the post display as comments the mentions on twitter. It seems working until the 1st mention is displayed then when mentions appeared as commments it says “comments are closed” if someone try to comment the post. How to fix it?

    http://wordpress.org/extend/plugins/live-blogging/

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author chrisnorthwood

    (@chrisnorthwood)

    Interesting, I can’t see anything in the code that would do that. Does it happen on different themes, or perhaps it’s an incompatibility with another plugin?

    Chris

    I’ve not any plugins using a twitter connection and also in the database the comments are marked as opened, there is the comment form and appears that comments are closed only after submitting a comment

    Additional information
    With my theme i didn’t get this problem on 17 december, i get it 20 december.
    I think is something related to my twitter oauth… but i don’t know how to remove the link from liveblogging to twitter to try without it

    Is still possible to put comments using reply for nested comments, so this bug is about only a new comment, not nested.

    It’s something related to this plugin 100%.
    I put an echo $comment_post_ID in wp-comments-post.php to see what post id is setted in the if ( !comments_open($comment_post_ID) )
    The id is the one of the 1st liveblogging entry, not the one of the post and in the database comment_status is settled as closed.
    The strange is that this happened only when twitter mentions arrived

    Did THIS code change the value of $comment_post_ID ?

    ` // Insert comment
    wp_insert_comment(array(
    ‘comment_post_ID’ => intval($b->name),
    ‘comment_author’ => $tweet->user->name . ‘ (@’ . $tweet->user->screen_name . ‘)’,
    ‘comment_author_email’ => $tweet->id . ‘@twitter.com’,
    ‘comment_author_url’ => ‘http://twitter.com/’ . $tweet->user->screen_name . ‘/status/’ . $tweet->id,
    ‘comment_content’ => $tweet->text,
    ‘user_id’ => 0,
    ‘comment_agent’ => ‘Live Blogging for WordPress Twitter Importer’,
    ‘comment_date’ => strftime(‘%Y-%m-%d %H:%M:%S’, strtotime($tweet->created_at) + (get_option( ‘gmt_offset’ ) * 3600)),
    ‘comment_approved’ => (get_option(‘comment_moderation’) == 1) ? 0 : 1
    ));

    Plugin Author chrisnorthwood

    (@chrisnorthwood)

    Are you using the latest version of the plugin?

    Yes, i tried also with previous versions but is the same.
    Maybe something related to wordpress 3.3 update?

    I also try with disable all the other plugins and using other themes but seems not something linking to it. If i disable the liveblogging plugin all it works and the value of comment_post_ID passed by commentform is the right one.

    Ok is nothing about twitter… simple the id changes when 1st liveblogging entry is sended.

    I did an attempt on a support site with a clean wordpress installation, installing only liveblogging and i get the same

    I did tests and with 2.2.1 all works fine, so it’s something changed later. With 2.2.2 i get this bug.

    Plugin Author chrisnorthwood

    (@chrisnorthwood)

    It sounds very similar to a bug that got fixed in 2.2.4. I’m confused as to which version you’re running, you said you were running the latest above, but then said 2.2.2 in your last post.

    Are you sure you’re running 2.2.4?

    Yes, i get the bug with 2.2.2, 2.2.3 and 2.2.4. don’t get it in 2.2.1

    Hi,

    Just to let you know that I faced the exact same issue today. Plugin version 2.2.4, WP 3.3

    As I placed the first live entry, the comments were no longer available. This is somewhat boring because on live events it is crucial to have reader’s feedback.

    I hope you can find a fix because this is a wonderful plugin and a terrific job. Congrats!

    Plugin Author chrisnorthwood

    (@chrisnorthwood)

    I can’t replicate this on 2.2.4 and WP 3.3.1 on a plain new install, I’d need more details to try and replicate this in order to fix the bug

    Chris

    That’s strange because i did it
    1) Install wp 3.3.1
    2) Install 2.2.4
    3) Put [liveblog] in the post
    4) Add a new liveblogging entry.
    That’s all…
    http://emmea.altervista.org/wordpress/?p=5
    You can find an example on my test site here, is a clean installation

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Plugin: Live Blogging] Comments closed when live?’ is closed to new replies.