Support » Plugin: List category posts » [Plugin: List category posts] Updated to Version 0.20.2 Now Plugin Doesn't work

  • Resolved kriskpooh


    My dashboard said there was an update for Catlist posts so I updated it but now my pages with the short codes don’t work. I had [catlist name=legal-briefs numberposts=-1] and the page is blank. I went and read the read me text and created a folder under my theme (which is suffusion) and put the default template file in there and that didn’t help. On another page it shows only one of the posts (there are two). At one point it showed the posts but they weren’t hyperlinked to the posts. I’ve been trying different aspects of the shortcode but neither id nor name is working.

Viewing 15 replies - 1 through 15 (of 16 total)
  • I also had problems after upgrading to 0.20.2. On some pages, only some of the posts matching the defined parameters were being displayed. On other pages, none of the posts were displayed.

    I have reverted back to 0.19.3, the version I was using previously, and everything is again displaying correctly.

    Same here. It looks like categories are working but tags are not.

    I saw that there was an update today. Updated to Version 0.20.3. Still doesn’t work.

    I must have originally installed 0.19.3 because I had to go back to that version in order to get the plugin to work correctly. 0.20 is the version where it no longer works with the existing shortcodes if that helps identify the issue.

    Plugin Author Fernando Briano


    Thanks for your patience guys!
    I managed to squeeze some time into a bugfix release today, please test version 0.20.4 and check if the tags issue is fixed. I’m not having much time for tests on every release, so any volunteers are more than welcome 🙂


    Nope. Just installed .20.4 and it still doesn’t work with category name or id. When I tried a tag, I got two posts that have no tags at all.

    Saw that .20.5 was available. Installed it. Still doesn’t work with category name. Went back to 19.3

    Plugin Author Fernando Briano


    Are you using templates? If you’re not, it’s not necessary for you to put the default template file on the theme’s folder. Just in case delete the file from there and let me know if that changes anything.

    I need as much info as you can provide regarding how you are using the plugin so that I can find the bug. When you say the shortcodes do not work, do you mean they don’t display anything? Do they display the wrong posts? Do they display the shortcode?

    At one point it showed the posts but they weren’t hyperlinked to the posts.

    This was a known bug which was recently fixed. Can you try to reproduce this situation?

    So, this is not working:
    [catlist name=legal-briefs numberposts=-1]
    Right? And you’ve tried with the ID and it doesn’t work either?

    I deleted the templates folder file and folder and it still did not work. The page with the shortcode is displaying blank. However, one page IS working correctly. The shortcode for it is [catlist name=web numberposts=-1]. I decided to try changing the category name from legal-briefs to just legal and now the page shows a list of 4 posts – the two posts in the web category, 1 post in the monthly-market-reports category and 1 post in the administration category. There is nothing else on the pages except the short code. The pages are however accessed managed using the User Access Manage Plugin. However, even a public page displays a blank page with the shortcode. Using catlist Id=7 also displays blank page. Using tag also brought up the 4 posts. I don’t see anything different in the set up of that one category that works – web – than in the other categories. I don’t have any tags except the two posts I tagged to see if the tag shortcode works. I will try disabling some other plugins to see if that is an issue.

    I deactivated all plugins except Lists category posts and still didn’t work. FYI my permalink structure is /%category%/%postname%/ Changing to the default one did not make it work either. I created a new category and 2 test posts and a test page with the short code for the new category name and that one worked. The 4 posts it finds when it finds posts were all created on or after 11-1-11. Changing the publication date of an existing post did not cause it to show up with the shortcode. However, when I created a NEW post and assigned it to the category – legal – now that post shows up on the Legal Briefs page with the shortcode but only that one new post. So it maybe something to do with the original publication date of a post?

    Createing a new category and applying it to old posts does not work either. Only New Posts or those created (not published) after 11-1-11 appear to work correctly.

    Plugin Author Fernando Briano


    kriskppoh, can you edit your wp-config.php and add the following code?
    define('WP_DEBUG', true);
    This will set WordPress to debug mode, and you’ll probably see some error regarding the plugin. If so, please paste the error here, because I haven’t figured out yet what’s going on here.

    This is what I got at the top of the page and it makes some, but not all of my sidebars go wonky with errors about the user access management plugin calling non-objects on line 927 and 477. I’ll look into changing the sidebar widget to see if that fixes it.

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/remax3g/public_html/e-tools/wp-includes/functions.php on line 3382

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/remax3g/public_html/e-tools/wp-includes/functions.php on line 3382

    Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home/remax3g/public_html/e-tools/wp-includes/functions.php on line 3382

    Notice: add_option was called with an argument that is deprecated since version 2.3 with no alternative available. in /home/remax3g/public_html/e-tools/wp-includes/functions.php on line 3468

    I think there is a problem with my installation or my database. I did a new install of WP, exported my content from my current configuration and imported it into the new install and the plugin appears to work correctly.

    I had a database corruption awhile ago from a bad plugin. Thought it was fixed but obviously something is still mucked up. Since this site isn’t live yet anyway, I will just go with the new installation.

    If no one else is having the problem, we can just assume I’ve got a database issue that is causing the problem.

    I will likely encounter further problems if I have a rogue db problem. Best to start over now before I go live.

    Plugin Author Fernando Briano


    Ok kriskpooh, glad you could export the configuration and start a new site. Who knows what happened then that made the plugin malfunction.

    From the debug code you showed, you were using an e-tools plugin which hadn’t been updated for a while. As you said, if you had issues now, better to start over if there’s not much damage in that.

    If you find any errors using List Category Posts in the future, please don’t hesitate to post it here with as many details as possible.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Plugin: List category posts] Updated to Version 0.20.2 Now Plugin Doesn't work’ is closed to new replies.