List category posts
Broken in WP 3.1 (6 posts)

  1. George Hahn
    Posted 5 years ago #

    I now get this warning on the page where I have the shortcode:

    Warning: Invalid argument supplied for foreach() in /data/21/2/110/161/2110976/user/2316208/htdocs/wp-content/themes/george/list-category-posts/default.php on line 36

    Until I upgraded to WP 3.1 yesterday, it worked perfectly.

    Otherwise, great plugin.


  2. drewshen
    Posted 5 years ago #

    this stopped working for me as well. was working perfectly until i updated wordpress.

  3. George Hahn
    Posted 5 years ago #

    I actually had the previous version of List Category Posts on another WordPress site. So I deleted the updated plugin, uploaded the previous version and installed it. It works.

    In conclusion... the latest version of this plugin is NOT compatible with WordPress 3.1, but the previous version of the plugin does work with WordPress 3.1.

  4. drewshen
    Posted 5 years ago #

    i removed the plugin altogether and just created a page template where i query that particular category. i liked it when it worked but i feel better now being dependent on one less plugin.

  5. fernandobt
    Plugin Author

    Posted 5 years ago #

    Hi George, drewshen,

    The error seems to be due to an update on the template system on version 0.18. Please, check the new included default.php and update your default.php file.

    I'm working on a new, improved, simpler system for templates, since this one is not really user friendly at all. Any feedback on the matter would be greatly appreciated. Check this link to a possible implementation.

  6. Cobber99
    Posted 5 years ago #

    Thanks for a great plug-in fernandobt! I too had the error, but now am good to go with the new default.php template file. With the older template system, I was able to hyperlink each thumbnail with the following code:

    //Show thumbnail?
    		$lcp_output .= '<div class="lcp_thumbnail"><a href="' . get_permalink($single->ID) . '">'. lcp_thumbnail($single) . '</a></div>';

    Do you have any ideas as to how to accomplish this in the new template version? I can't seem to figure it out.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • List category posts
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic