WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Links in Captions] Awesome Plugin! Title Tags Not Working Properly

[Plugin: Links in Captions] Awesome Plugin! Title Tags Not Working Properly

  • Tevya
    Participant

    @thefiddler

    When I do the code for the caption, I put “Open website in a new window” for the title tag. But when I hover over the link on the website it only says “Open”.

    Is this a problem anyone else is having? Is there a fix for it, or something that needs to be updated in the plugin?

    This plugin solves such a huge problem. They keep putting off fixing it in WordPress itself.

    http://wordpress.org/extend/plugins/links-in-captions/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Zack Katz
    Participant

    @katzwebdesign

    Can you please post the exact code you’re using for your caption?

    Tevya
    Participant

    @thefiddler

    Sure. Its
    {link url="http://nampanewfies.com" target="new" title="Open website in a new window"}Newfoundland Dogs{/link}

    Its on the Business Websites page of my website. Just hover over any of the captions for the “Examples” and you’ll see it just shows the first word “Open”.

    Plugin Author Zack Katz
    Participant

    @katzwebdesign

    Have you tried using single quotes instead of double?

    {link url='http://nampanewfies.com' target='new' title='Open website in a new window'}Newfoundland Dogs{/link}

    Let me know if that works; if it does, I’ll see what I can change in the code.…

    Tevya
    Participant

    @thefiddler

    One quote displays “‘Open”, no quotes displays “Open” (just the stuff inside the double quotes).

    Thanks for looking into this Zack. Great plugin.

    Plugin Author Zack Katz
    Participant

    @katzwebdesign

    Hi Tevya,
    Thanks for pointing out this issue; indeed, the plugin wasn’t generating wrapping quotes for the title attribute. I just released version 1.2 that fixes the issue and also adds {a} support instead of only {link}; this will allow a more natural {a href="http://example.com"}Example{/a} for people used to HTML.

    Tevya
    Participant

    @thefiddler

    Awesome Zack! Thanks. Its a much needed plugin, so glad you created it.

    Yes Zack, I concur this is a perfect (and simplest) solution.

    I used this throughout a portfolio site. I did find some occurrences where I would either link to an external site or to an internal PDF and the tickmarks entered in the caption field turned to quotes, not immediately, but when switching from HTML view to Visual view during the work process.

    This would make the link to a site be “http://thisdomain.com/”http://linkeddomain.com”

    I found that using either the HTML character entities " or leaving out the tickmarks was more stable. Followed a logical workflow when applying so fairly sure I did everything correctly.

    Nonetheless, this saved the day–thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Links in Captions] Awesome Plugin! Title Tags Not Working Properly’ is closed to new replies.