Support » Plugin: Link Library » [Plugin: Link Library] User submission form won't show up

  • Resolved dking64


    I wrote earlier that user submissions were not coming through. After testing, the issue is larger: I created a new Link Library and put the shortcodes on a new page — “Display link submission form” doesn’t show up at all, so something deeper is wrong with the link submission form. I uninstalled and reinstalled LL; deactivated all other plugins and that didn’t fix it; and I installed LL on another WP site of mine and no problems. So if the problem isn’t fixed by a reinstall or deactivating all other plugins, I have to wonder if there’s some problem in my database.

    Any suggestions on figuring this one out? User submission has been down on my site for some time and I need to solve this asap. Thanks again.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Yannick Lefebvre


    Sorry that you are having all of these problems. Things have been a bit hectic in my life recently. I will try to run a couple of tests tonight on a clean install and see what I find. I expect that you are running version 4.9.7, right?

    Can you export your settings and send them to me using my contact form at This way I can import your settings and see if anything is misconfigured. Alternatively, you could take screenshots of your admin panel for Link Library and post them on a picture sharing site for me to see.


    Thanks very much.

    I have exported all the settings but your contact form seems to have a captcha that doesn’t display in the two browser’s I’ve tried.

    Also, I have the settings exports in a zipped folder, which your contact form doesn’t like, so let me know if there’s another way to get this .zip to you.

    Ssettings exports can be downloaded here:

    Thank you very much for looking into this.

    Plugin Author Yannick Lefebvre


    I am seeing 7 different setting sets inside of the zip file. Which one are you using on the page where the link submission is not showing up?

    Also, can you show me the shortcode calls that you are using on your page?

    Plugin Author Yannick Lefebvre


    I tried importing the first setting set and was able to display a form using it. So this is why I am asking extra questions.

    Thanks for following up.

    The user submission form *does* display for all 7 of our existing libraries. However, submissions don’t go anywhere — I don’t see any of my many test submissions in the database.

    The user submission form *does not* show on any NEW library. I created a new, 8th library as a test, left all the default settings in place, then created a fresh test page with all four shortcodes for this. The links, categories, and search all display on the test page, but the user form does not display.

    The submission form shortcode used for this test is [link-library-addlink settings=8]. I didn’t send you the settings for this library because they’re all just the default.

    any thoughts?

    Plugin Author Yannick Lefebvre


    I have not had the time to go back since you gave me your last answers. This week is particularly busy for me and working on plugins is something I do in my spare time. I will most likely only have time to look at this Sunday or Monday night as I have a wedding rehearsal to attend tonight and the actual wedding tomorrow.

    I completely understand and sorry for pushing. I’m up against a deadline since the user submission has been down for so long so I think I may have to try to delete everything and rebuild all seven of our libraries manually this weekend using exported data. So if you have time to answer, please let me know how I might best go about purging all LL data from the database so that I’m starting from as clean a slate as possible.

    My hope is to root out any problem that might reside in the database, as it seems we’ve isolated everything else. Thanks again for your help.

    Plugin Author Yannick Lefebvre


    First, a quick suggestion, can you try going in the plugins page and deactivating, then reactivating the plugin. Once this is done, try to submit a link again. Just to be sure that all updates to the data schema are in place and that the link addition does not just fail because of a missing field.

    As for restarting from scratch, you should do the following:
    – In your MySQL admin, delete the rows that have LinkLibraryGeneral and LinkLibraryPPx (where x is the setting set #) from the WordPress options table

    – A bit more extreme but also more destructive would be to delete the links_extrainfo table that gets created by Link Library but that would delete any data stored in the Link additional fields in the links editor.

    What I can offer would be to do some debugging directly on your site to be sure that I am working in the problematic environment. I could do that on Sunday night. Would you be open to giving me admin access to your site? I just updated my personal site to the latest version and was able to submit a new link successfully. Being on the actual server would definitely help.

    Thank you very much — I would be more than happy to give you access. Can you please email me directly at

    I deactivated and reactivated the plugin and the link submissions still seem to go nowhere.

    FYI, ignore what I said about new user submission forms not showing up on new test pages. I figured out what was happening there. So the only issue that needs to be resolved is the fact that user submissions aren’t being written to the database as fas as I can tell.

    Thanks, Y.

    I’ll send you the info using your contact form. Thanks.

    I forgot I can’t do that — can’t get past the missing captcha on your form. Please email at and I’ll give it to you immediately. Thanks.

    For others who might have this problem, here’s the solution in my case: The page I created at the “Link Acknowledgment URL” did not have the shortcode “[link-library-addlinkcustommsg]” and so the submissions failed.

    In the current version of Link Library, the instruction to add this shortcode — which is necessary to make the submissions forms function — is hidden in a tooltip that appears when you mouse over the label for the field where you enter this URL in the Link Library admin settings.

    The developer figured out the source of my problem and said he will change this in the next update so the instruction appears next to the field and not just in the tooltip.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: Link Library] User submission form won't show up’ is closed to new replies.