WordPress.org

Ready to get started?Download WordPress

Forums

Link Library
[resolved] escaped characters (4 posts)

  1. dking64
    Member
    Posted 3 years ago #

    In the "Additional Link Parameters" on the "Edit Link" screen, special characters are escaped when you save. If you go back and edit that link, the escaped characters will be escaped again when you save the changes. So you have to "un-escape" special characters every time you edit a link, otherwise you accumulate the "\" character before each instance of special characters.

    Perhaps this is part of the "Link" functionality and not specific to Link Library. But, if not, it would be great if the system checked whether special characters are already escaped instead of re-escaping them.

    http://wordpress.org/extend/plugins/link-library/

  2. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    Version 5.0.3 will contain the appropriates updates to un-escape the special charcaters. It will be available a bit later today.

  3. dking64
    Member
    Posted 3 years ago #

    Seems to be working. Thanks!

    I also like the display-category-as-select-list option. Nice work!

  4. Yannick Lefebvre
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks :) That select list idea came from a user and I don't know why I never thought about it before. It does look pretty slick.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic