WordPress.org

Forums

Like-Button-Plugin-For-Wordpress
[resolved] PHP error on activate of 4.4.3 (9 posts)

  1. dropdeadfred
    Member
    Posted 4 years ago #

    Get this error on activate:

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/leadi7/public_html/blog/wp-content/plugins/like-button-plugin-for-wordpress/admin/gb_admin_header.php on line 25

    I suppose it could be a PHP issue on my host, but I've been running this blog fine for years without issues.

  2. GBWorld
    Member
    Plugin Author

    Posted 4 years ago #

    Hello dropdeadfred.

    You are not the first one with this error but like I told the other people too in this line there is only an 'public static function' command which should run properly on every host. But you are not the only one which this problem.

    I will try to fix this and use another way to call this function. I am sorry that this problem occurs on your blog. Have you tried to downgrade to 4.3.2? This version should work properly until this is fixed.

    Regards.

  3. dropdeadfred
    Member
    Posted 4 years ago #

    Thank you for the quick response. That's why I chose this plugin over some other options as it looked like someone actively maintained it and still cared about it.

    I will give the downgrade to 4.3.2 a try. Thanks!

  4. GBWorld
    Member
    Plugin Author

    Posted 4 years ago #

    Thanks a lot. I wrote a note on my development board and I will try to fix it until the next update. When the update is ready and you've installed it give me another feedback please if it works.

    Regards.

  5. dropdeadfred
    Member
    Posted 4 years ago #

    Tried the 4.3.2 and had a similar problem.

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/leadi7/public_html/blog/wp-content/plugins/like-button-plugin-for-wordpress/admin/gb_admin_header.php on line 26

    However I realized that lunarpages had switched me back to PHP 4.x.

    I switched to PHP5 and 4.3.2 worked fine. I bet the lastest version will too.

  6. dropdeadfred
    Member
    Posted 4 years ago #

    Yep 4.4.3 works now on PHP5. Should have known something was up.

    Thanks

  7. GBWorld
    Member
    Plugin Author

    Posted 4 years ago #

    Thanks a lot. Good to know :)

  8. rssolo23
    Member
    Posted 4 years ago #

    I'm just confirming that updating to PHP 5 resolved the issue with me, too. Luckily I didn't have to downgrade.

    Thanks GBWorld for making an awesome plugin :)

  9. GBWorld
    Member
    Plugin Author

    Posted 4 years ago #

    Thanks for this positive Feedback :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Like-Button-Plugin-For-Wordpress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic