[resolved] Nothing happens (9 posts)

  1. johnpeterraven
    Posted 4 years ago #


    Today I updated the plugin to version 4.4. But disappointing enough, it deleted all my previous setting, which I wasn't expecting. Since the plugin (and it's ability to configurate) is pretty extensive.

    Yet, when I tried to put everything back I noticed pressing the 'save changes' doesn't save the configurations.

    Any suggestions what I could do or what has happened?




  2. johnpeterraven
    Posted 4 years ago #

    Tried to deactivate the plugin, but it just gives me back a blank page.

    After that I simply delete it (via FTP) and tried to install it back again (via admin). This also wasn't possible and gave me back this message:

    Plugin could not be activated because it triggered a fatal error.

  3. Tuzo81
    Posted 4 years ago #

    Have the same problems :)
    Want to activate the button and get the msg:

    Warning: Invalid argument supplied for foreach() in .../httpdocs/wp-content/plugins/like-button-plugin-for-wordpress/admin/gb_save.php on line 55

    Warning: Invalid argument supplied for foreach() in .../httpdocs/wp-content/plugins/like-button-plugin-for-wordpress/admin/gb_save.php on line 96

    Want to deactivate the Plugin and get a blank page with the msg

    Fatal error: Call to undefined method GBLikeButton::rot13encrypt() in .../httpdocs/wp-content/plugins/like-button-plugin-for-wordpress/gb_fb-like-button.php on line 521

  4. GBWorld
    Plugin Author

    Posted 4 years ago #

    I am sorry for this errors but I know what you can do to fix this problems:

    1. Run the GBCleaner on the Settings-Page to fix the problems with the foreach-coding
    2. download and update to the latest 4.4.1 version. I patched those lines.

    thx and sorry for all the bugs...


  5. Tuzo81
    Posted 4 years ago #

    Hmm 2 Hours ago the cleaner doesn't helb. But now ist works (also without step 2 downloading 4.4.1)....puh, thx for your fast and great help

    Best Regards

  6. johnpeterraven
    Posted 4 years ago #

    Thanks! Everything seems to function like it should.

    Thanks again for your quick respond!

    Best, Peter.

  7. atlohi
    Posted 4 years ago #

    Another thanks for the quick response!

  8. davidsanger
    Posted 4 years ago #

    I have just installed the plugin for the first time. Sorry for cross posting but didn'y get any response on Facebook, Twitter or the bug reporting.

    Installed the plugin for the very first time 4.4.1 with WP 3.1 Mac OS 10.6.6

    I cannot activate the "Like" button because in every browser, Chrome, FF and Safari, theDesign tab does not work so I cannot set Position Settings.

    All the entries on the first tab are fine but I cannot get to the other tabs. Inspector shows the code is there but the tab does not display.

    GB-Warning-System (Refresh for Update)
    Activation: Please activate the Like Button in order to use and see the Button on your Blog. [General]

    What do you suggest to help you debug this?

    I uninstalled and reinstalled, cleared cache, tried multiple browsers, restarted , all to no avail.

    This is not an upgrade , but a brand new install.

  9. GBWorld
    Plugin Author

    Posted 4 years ago #

    Hello davidsanger.

    Could you post the Debugger Notes of your browser please? This could help me to find the jQuery bug because it seems that this is a jQuery bug. Thanks.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Like-Button-Plugin-For-Wordpress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic