WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Like-Button-Plugin-For-WordPress] 4.4.1 Upgrade Broken

[Resolved] [Plugin: Like-Button-Plugin-For-WordPress] 4.4.1 Upgrade Broken

  • InHouse
    Participant

    @inhouse

    Not sure what happened but when I upgraded the plugin to 4.4.1, the Like button disappeared from my pages/posts and the admin won’t function properly. I click “activate the like button” and “save changes” and I get the message saying the changes were saved; however, the admin page has reverted back to unactivated it appears. Is this why the like buttons have disappeared from my site? All I see on the pages is “[like url=http://www.scoopsriverpark.com/posh/before-after-gallery]” where they used to be displayed. Thanks.

Viewing 15 replies - 1 through 15 (of 18 total)
  • davidsanger
    Member

    @davidsanger

    SImilar problem.

    Just installed plugin v4.4.1 as a new install.

    Cannot activate plugin because tabs do not work on settings page

    GB-Warning-System (Refresh for Update)
    Activation: Please activate the Like Button in order to use and see the Button on your Blog. [General]

    No response from owner on blog, Facebook Twitter or here so far.

    Plugin Author GBWorld
    Member

    @gbworld

    Hello to both of you.

    Could you tell me which version of wordpress do you use? And could you also use the Debugger of your browser to show me what errors you get? This could help me to help you.

    @davidsanger: After you click ‘Refresh’ the message should disappear. But you only if you activate the Button (via checkbox on the General page).

    Regards.

    davidsanger
    Member

    @davidsanger

    @gbworld

    Refresh didn’t work because I was never able to get to the Position Settings panel.

    I found what I think is the problem. I use the Disqus plugin and saw in the source code of my admin panel this script added by Disqus.

    <script type=”text/javascript”>
    jQuery(function($) {
    // fix menu
    var mc = $(‘#menu-comments’);
    mc.find(‘a.wp-has-submenu’).attr(‘href’, ‘edit-comments.php?page=disqus’).end().find(‘.wp-submenu li:has(a[href=edit-comments.php?page=disqus])’).prependTo(mc.find(‘.wp-submenu ul’));
    });
    </script>

    This script was not present in the other blog I installed the Like button plugin on.

    When I deactivated Disqus the tabs worked.

    But I need Disqus

    Plugin Author GBWorld
    Member

    @gbworld

    I already answered on bugs.gb-world.net. Could we please discuss this on bugs.gb-world.net only? Because then this bug is only discussed about on one single page 🙂 🙂 if this is ok for you.

    GB-Bugtracker Ticket: http://bugs.gb-world.net/view.php?id=43

    Regards

    davidsanger
    Member

    @davidsanger

    OK fine….

    InHouse
    Participant

    @inhouse

    The upgrade to 4.4.2 didn’t change anything for me so I deactivated the plugin. I even re-installed. When you try to “activate the like button” within admin screen of plugin, and save, it confirms you saved but then the radio button is not checked anymore. And no like buttons on webpages. I am using WordPress 3.1. I liked the plugin but don’t have time to wait for a fix.

    Adrian
    Member

    @gabberkopf

    Same Problem here.
    Got the two error messages:

    Warning: Invalid argument supplied for foreach() in /home/xxx/public_html/wp-content/plugins/like-button-plugin-for-wordpress/admin/gb_save.php on line 55

    Warning: Invalid argument supplied for foreach() in /home/xxx/public_html/wp-content/plugins/like-button-plugin-for-wordpress/admin/gb_save.php on line 96

    All settings i made in previous version are lost

    Plugin Author GBWorld
    Member

    @gbworld

    Just run the GBCleaner on the Settingspage and everything is back again.

    Regards.

    Iva
    Member

    @supersonicsquirrel

    I just wonder why we have to re-check all of the settings each time we upgrade. Shouldn’t that be more consistent? Last time I upgraded, it changed my post-specific button for a site-wide button and it took me a while to notice.

    I’m not being an ingrate, I only hope if this can be improved. 🙂

    Iva
    Member

    @supersonicsquirrel

    It just doesn’t work, either way. 🙁

    When I run the cleaner, it logs me out of WordPress.

    Iva
    Member

    @supersonicsquirrel

    Disregard my last reply, it worked after seven times.

    Plugin Author GBWorld
    Member

    @gbworld

    @iva: I am sorry that this re-check happens after the update to 4.4 (before 12 march). It has been fixed in the meanwhile and should not happen again. We do not plan to change the settings in the future again and then it should work fine.

    It logged you out of WordPress? Really? That is strange and should not happen. The next release which will probably be online today fixes some reports of other users but now it seems that your problem is fixed.

    Regards.

    Iva
    Member

    @supersonicsquirrel

    Now it works like a charm, thank you. 🙂

    And I’m sorry if the above sounded odd – was not meant to.

    InHouse
    Participant

    @inhouse

    Installed this plugin on a new website I’m building and upon activation, it deletes the content of the page. Simple About Us page text got replaced by the Like button. Previous issue on my other website was that it was interfering with the Like Box in my sidebar but this site is missing all the page content. I had to deactivate it. WordPress 3.1 and 4.4.

    Iva
    Member

    @supersonicsquirrel

    In order not to start a new thread: you forgot script type and each page with this plugin on it will have another validation error (next to W3 obviously not recognising meta attribute. Just thought I’d give you a heads-up.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] [Plugin: Like-Button-Plugin-For-WordPress] 4.4.1 Upgrade Broken’ is closed to new replies.