WordPress.org

Forums

[Plugin: Lightview Plus] Not GPL compatible? (11 posts)

  1. dkruyt
    Member
    Posted 7 years ago #

    Hi, this plugin comes with lightview. But all plugins must be GPL and lightview is not GPL, take a look at the license down here.
    So, you should remove the lightview JS from this plugin and tell people to get lightview from the site conform the license.

    Lightview License:
    #
    Non-Commercial
    Single domain
    A small fee is required for non-commercial use. This is used to keep Lightview available and up-to-date for everyone.
    #
    Non-Commercial
    Unlimited
    Get permission to use Lightview and future updates on all the non-commercial websites you develop in the future, at no further cost.
    #
    Commercial
    Single domain
    This will give you permission to use Lightview on a single commercial domain. Meaning any website that derives revenue by selling products, services or advertising.
    #
    Commercial
    Unlimited
    With unlimited permission you are allowed to use Lightview and all future updates on any commercial website you develop in the future, at no further cost.

  2. puzich
    Member
    Posted 7 years ago #

    http://wordpress.org/extend/plugins/lightview-plus/installation/

    There you can read die license informations!

  3. wasabi22
    Member
    Posted 7 years ago #

    puzich: The license info you have there is incorrect.

    That should be changed, it's not free for commercial use. What dkruyt posted is correct, check out the official lightview website.

  4. puzich
    Member
    Posted 7 years ago #

    Why is my license information incorrect?

    I talked with the author of lightview and he asked me to write these license informations!

  5. Your license information says: "Lightview is free for use on non-commercial websites."

    That is incorrect. This:
    http://www.nickstakenburg.com/projects/lightview/#license

    Says it's $3 for use.

    Furthermore, regardless of this, that form of license is not GPL compatible in any way. You need to either remove the lightview code from your plugin, or the plugin will be removed from the WordPress Extend section. Plugins listed here on wordpress.org must be GPL compatible.

  6. puzich
    Member
    Posted 7 years ago #

    Oh, since my last update, lightview.js was free for non-commercial. I have to write to the author...

  7. It would not matter even then. Even if it was free for non-commercial, it would still not be GPL Compatible and cannot be listed on wordpress.org.

  8. wasabi22
    Member
    Posted 7 years ago #

    When lightview is not in your plugin it's okay, people should download it themselves like dkruyt said so they can conform to the license on the dependancy.

  9. puzich
    Member
    Posted 7 years ago #

    OK, I will remove lightview-js. Please, give me one week. I am on the move to an other city and only have wlan-access from my car. Thanks!

  10. puzich
    Member
    Posted 7 years ago #

    OK, I removed lightview javascript and I hope, that I'm within all license terms, now!

  11. wasabi22
    Member
    Posted 7 years ago #

    I see nothing mentioned about lightviews license terms, but the rest seems okay

Topic Closed

This topic has been closed to new replies.

About this Topic