WordPress.org

Forums

[Plugin: Lightbox 2] v2.7 still not working in IE7 (10 posts)

  1. fluvius
    Member
    Posted 7 years ago #

    Just updated to v2.7 of the plugin but it's still not working in IE7. I just get the relevant image on an otherwise blank page, just as it would if the plugin weren't installed.

    Things work fine on FF, Opera and Safari however.

    Tony.

    http://wordpress.org/extend/plugins/lightbox-2/

  2. stevedmma
    Member
    Posted 7 years ago #

    yeah it doesnt work great at all in IE......

    I wouldn't care but as much as people deny it IE is still the most used browser.

    I use FF but my visitors probably do not.

  3. area97
    Member
    Posted 7 years ago #

    to me, in IE, does not overlay flash banners and does not display title, well, it displays title always as "null"

  4. stimuli
    Member
    Posted 7 years ago #

    Read the updated FAQ included in 2.7.4. Not sure why 2.7.4 is not shown as the current download....

    http://wordpress.org/extend/plugins/lightbox-2/download/

    SHort answer: the problem is neither LB nor IE. A visit to my site confirms that, as I have always checked in both IE6 and 7....

  5. Stephr0x0rs
    Member
    Posted 7 years ago #

    I'm using 2.7.5 and the bottom caption/close/prev/next images don't show up at all in IE7.

  6. Anonymous
    Unregistered
    Posted 7 years ago #

    i have this exact same problem.. i just bought a brand new Dell laptop 7/2008 running vista home premium.. and on FF works great... but on my IE it dim the page.. but then open the image onto a new page.. just like w/o the plugin install.. all my other computers run on win XP and doesn't have this problem.... i went onto the plug-in homepage http://stimuli.ca/lightbox/ to test it out as well.. same problem... i guess it has something to do with the browser setting? i hope someone would know how to solve this problem...

  7. Anonymous
    Unregistered
    Posted 7 years ago #

    i found something else too..
    if you go to my website http://3down7up.com and when you click on any image it would open a new page.. but when you go to the photos section http://www.3down7up.com/photo-albums/allan-hangs-engagement-ii/# and click on the image.. it worked.. but not properly.. it pop up another window showing the same image.. please help look into this.. thanks!!!

  8. Anonymous
    Unregistered
    Posted 7 years ago #

    i found the fix from here http://www.huddletogether.com/forum/comments.php?DiscussionID=600

    First put the following code on top of the lightbox.js:
    var IE = document.all?true:false;

    function GiveFalse() {
    if(IE) {
    event.returnValue = false;
    }
    return false;
    }

    Now search for the following line:
    anchor.onclick = function () {myLightbox.start(this); return false;}

    and change it to:
    anchor.onclick = function () {myLightbox.start(this); GiveFalse();return false;}

  9. Fer Pont
    Member
    Posted 7 years ago #

    I´m experiencing the same problem. Tried all the above mods but no cigar... here's a text site, please somebody try it on IE 6:
    http://centroculturalrecoleta.org/ccr-sp/comollegar/

    Could some css be preventing it to working right?
    here the css effecting images in the post:

    .entry{ margin-bottom:8px; border-top:1px dotted #999999;min-height:160px;}
    .entry img {float:left;margin:0 10px 4px 0;border: 1px solid #cccccc; height:140px; width:140px; overflow:hidden;
    }
    .entry p{padding-top:6px; width:520px;height:160px;
    }

    I stand perplexed... :(

  10. Fer Pont
    Member
    Posted 6 years ago #

    Ok... I solved it! It was just a collision between mootools and lightbox. Since I was using a mod of the "Massive News" theme, which had a call to scripts involving motools, I just commented the 3 calls to these scripts, and voila! the problem dissapeared...
    This is what I commmented, inn the header.php:

    <script src="<?php bloginfo('template_directory'); ?>/scripts/mootools.v1.11.js" type="text/javascript"></script>
        <script src="<?php bloginfo('template_directory'); ?>/scripts/jd.gallery.js" type="text/javascript"></script>
        <script src="<?php bloginfo('template_directory'); ?>/scripts/jd.gallery.transitions.js" type="text/javascript"></script>

    :D

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags