WordPress.org

Support

Support » Plugins and Hacks » Lightbox 2 » [Plugin: Lightbox 2] Not functional WordPress 3.1 and IE8

[Plugin: Lightbox 2] Not functional WordPress 3.1 and IE8

  • Ever since upgrading to wordpress 3.1, the lightbox2 plugin has stopped functioning unless I put IE8 into compatibility mode. Then it works as expected. I would rather not have to change the theme if I don’t have to. (In firefox it works as expected…)

    kparnell

Viewing 5 replies - 1 through 5 (of 5 total)
  • Same issue here. Do we know if the author of the plugin is working on a new version?

    No signs of activity on their web site, but it worked perfectly until the wordpress 3.1 update. I’m guessing that’s where the problem lies…

    Just came across a temporary fix that worked for me at http://wordpress.org/support/topic/lightbox-2-doesnt-work-in-firefox-with-wp-31?replies=22

    Replace the new /wp-includes/js/jquery/jquery.js with one from an older version or WordPress – I used jquery.js from 3.04 and it works like a charm!

    P.J.

    Had a similar issue where there was a conflict between Nivo and Lightbox 2 which was only showing up in IE8.

    Fix in the end was to roll back the prototype.js version supplied with WordPress (/wp-includes/js/prototype.js) from 1.6.1 to 1.6.0.2 which I luckily had lying around from a previous project.

    Hope this info spares someone the time I spent searching for a solution…

    THANKS hd.design.

    Super-quick fix that definitely worked (I used the prototype.js from WP 2.8.4)

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Lightbox 2] Not functional WordPress 3.1 and IE8’ is closed to new replies.
Skip to toolbar