WordPress.org

Forums

leenk.me
[resolved] Could not open handle... (2 posts)

  1. EricaMueller
    Member
    Posted 4 years ago #

    I get the message below whenever I try to authenticate the API or send a test post...

    Could not open handle for fopen() to https://leenk.me/api/1.1/

    What do I need to do?

    http://wordpress.org/extend/plugins/leenkme/

  2. Lew Ayotte
    Member
    Plugin Author

    Posted 4 years ago #

    Hello,

    Sounds like you do not have cURL enabled on your web host. fopen doesn't like using https very much. Here is a work around:

    function my_leenkme_api_url( $url ) {
        $url = str_replace( 'https', 'http', $url );
        return $url;
    }
    add_filter( 'leenkme_api_url', 'my_leenkme_api_url', 10 );

    Add that code to your theme's functions.php file.

    Let me know if that doesn't help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • leenk.me
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags