Support » Plugins » [Plugin: LeagueManager] Results are not saved

  • Hi,
    I have been running League Manager 2.4 from a few weeks but suddenly it does not save the results I write in the matches forms. It is a league with 18 teams and I have programmed 45 matches, but now it does not save the results I insert and of course the clasification table shows only zeros in all the fields, with no results.

    Anyone else is having this problem?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Hi,

    did you want to save the result by hitting “Enter”? This does not work, because there are two submit buttons, one for deleting matches and the other for saving results. If you hit the “Save results” button with the mouse it should work

    Hi koelle,
    thanks for answer. I have noticed that “two buttons” thing, that is not the problem, I am saving the matches and then they appear on the results table, I can write the results but I click on the bottom button (last button) to save and it does not save the results, it shows me all the text inputs blank, with no results (in fact, the results which were saved right they also dissapear and are established to an “empty result”).

    I am running WordPress 2.6.5. Oh, and I have a Spanish translation of League Manager. How can I send it to you?

    Thank you very much for your great job.


    did you try to deactivate and re-activate the plugin? What version of LeagueManager are you using?

    You can send me the Spanish translation to kolja.schleich at

    I am using WordPress 2.6.5 and League Manager 2.4. I am trying deactivating and activating the plugin again, but it does not work.
    I have 5 leagues with many teams and 32 matches each, with their 32 results with no problems. But there’s one league with 102 matches and this is the league which is not saving the results. All the inputs are shown empty, but the other leagues are saving the results ok.

    I have seen the DB with PHPMyAdmin and I think that the results are not being saved…

    I don’t know what else can I try…

    Thank you very much for your support.

    Oh, and I’ll send you the Spanish translation to your mail, 🙂

    OK, so the plugin works fine for 32 matches, but not for 102 matches, correct? I will have a look at what could be the cause for this.

    If you upgraded the plugin to Version 2.4 the problem could be that the database tables were not correctly created. I’ve just released 2.4.1, after de- and re-activation of the plugin it should work.

    Thank you very much and congratulations for the plugin update. I am trying it and I think it’s solved. I have sent you the Spanish translation of League Manager to your mail address.

    Hi just tested 2.4.1 and am getting the following error:

    Parse error: parse error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in ../wp-content/plugins/leaguemanager/leaguemanager.php on line 1631

    any ideas


    was reading about the error. I am running php4 would this be the problem reguarding the error i received.


    I have seen that 2.4.1 just let to add matches on 2009 and 2010. Is there any way to add matches and its results in a 2008 date? I mean to get a real clasification of this 2008-09 season…

    sure this is possible. For now you can simply change the following in match.php

    <?php for ( $year = date(“Y”); $year <= date(“Y”)+1; $year++ ) : ?>


    <?php for ( $year = date(“Y”)-1; $year <= date(“Y”)+1; $year++ ) : ?>

    I will implement this in the next release, but would like to wait a few days if any new bugs pop up. This code should be in line 58.

    Alternatively you can download math.php from the development version and upload it to your blog.

    @endorpha. Yes this error is due to your PHP version. Just delete the public in front of the function definition.

    Alternatively you can download leaguemanager.php from the development version and upload it to your blog.

    Thanks, it worked right!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: LeagueManager] Results are not saved’ is closed to new replies.