Support » Plugin: Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) » [Plugin: Leaflet Maps Marker] How do I remove the shadow of each icon on the map?

Viewing 10 replies - 1 through 10 (of 10 total)
  • in the leaflet.css on line 131 set
    .leaflet-shadow-pane to display: none;

    Plugin Author RobertHarm

    (@harmr)

    thanks for helping with support question! 🙂

    BTW: if you like using my plugin, please vote for it on wordpress.org 😉

    renefred

    (@renefred)

    Hi,

    I’ve tried to fix a shadow problem. I get a broken image link in Safari and Chrome:

    Nationalparker i USA

    The shadow image is there:
    http://www.renefrederiksen.dk/wp-content/plugins/leaflet-maps-marker/leaflet-dist/images/marker-shadow.png

    But just not showing.

    I’ve also tried to edit the css and set the shadow to none, but nothing seems to help.

    Plugin Author RobertHarm

    (@harmr)

    you switched to Google Maps? what a pitty 😉

    renefred

    (@renefred)

    I didn’t switch. I tried out with google maps to begin with, but shouldn’t it be possible either to fix the shadow problem (broken image link just behind the icon) or remove the drop shadow completely?

    Plugin Author RobertHarm

    (@harmr)

    it’s difficult to analyse a problem that seems to be affecting only your installation – do you have a test site with a demo map?

    renefred

    (@renefred)

    I just put the plugin on a test site and there it works, so it is probably something on this site thats to blame.

    Just to be sure I did the CSS change correct, van you show how I switch it off?

    This is what I see near line 131:

    .leaflet-container img {
    max-width: none !important;
    border:none !important;
    background:no-repeat !important;
    padding:0px;
    margin:0px;
    }
    .leaflet-objects-pane { z-index: 3; }
    .leaflet-overlay-pane { z-index: 4; }
    .leaflet-shadow-pane { z-index: 5; }
    .leaflet-marker-pane { z-index: 6; }
    .leaflet-popup-pane { z-index: 7; }
    .leaflet-zoom-box {
    width: 0;
    height: 0;
    }
    .leaflet-tile {
    visibility: hidden;
    }
    .leaflet-tile-loaded {
    visibility: inherit;

    renefred

    (@renefred)

    I found the reason. A plugin, Better WordPress Minify, is the cause of the problem. Would still like a solution for the CSS to turn it off completely in case I get a lot of icons.

    Plugin Author RobertHarm

    (@harmr)

    Please check this faq: http://www.mapsmarker.com/faq/how-do-i-change-the-shadow-of-markers/

    Ad WordPress Minify plugin – will enhance the compatibility checks in v2.6 – thanks for letting me know…

    Plugin Author RobertHarm

    (@harmr)

    FYI: v2.7.1 which I just released offers a new setting under Marker/Icons/Popups-tab: if you leave the field “shadow URL” empty, no shadow will be displayed for marker icons. No need to edit css-files on each update anymore 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Leaflet Maps Marker] How do I remove the shadow of each icon on the map?’ is closed to new replies.