Support » Plugin: Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) » [Plugin: Leaflet Maps Marker] Flash player is not showing up (FF and Safari only)

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author RobertHarm

    (@harmr)

    strange – I checked your site but couldnt find any clue why it is not displaying in FF or Safari – no console log entry, on error. I tried changing css with firebug but with no effect…perhaps you could check if there is a new version of your audio flash player available. I´d also advise posting a support ticket at the site of the programmer of the audio flash player. A ticket at https://github.com/CloudMade/Leaflet could eventually help to…
    You could also try disabling all other plugins to see if there is a plugin conflict and change to another theme to see if that´s the reason…
    hope, this helps!

    Thanks Robert, I have switched the plugins off, changed the theme and updated the player – but neither has helped, sorry ( When browsing in Safari the player shows up but not where it meant to be – strangely off-axis, in the upper-left corner a few centimeters away.

    Plugin Author RobertHarm

    (@harmr)

    I will take a look at it later…

    Plugin Author RobertHarm

    (@harmr)

    I’d advise posting a $5-question on wpquestion.com – I am pretty sure you will get an answer for the problem. Just let me know if the fix has to do with my plugins css in order to include it in the next release…

    Plugin Author RobertHarm

    (@harmr)

    hi again,
    try adding <param name=”wmode” value=”transparent”> to the <object>-tag in popups – this worked for me.
    regards,
    Robert

    Hello, it works, many thanks indeed! Now I have to find the way to place the tag into each popup the easy way (there are around 200 of them on my map). It would be great to be able to change the parameter in the dashboard one day. But anyway – thanks again for your support Robert, Maps Marker is an awesome plugin, and your effort is amazing.

    Plugin Author RobertHarm

    (@harmr)

    thanks for your kind words and great that the solution works for you! ad changing all popups: I would download all markers via phpmyadmin as insert statements, open the file with notepad, search+replace the code in question, delete all old entries from leafletmapsmarker_markers (backup first!) & then reimport the changed markers via sql insert statements
    regards,
    Robert

    Wow, this sounds like magic to the not so tech-savvy but I should try anyway. One more question – will this affect the loading time?

    Ouch! Adding this tag makes the flash player disappear from the popup in Opera instead, but it’s fine with FF. It was ok in both before 2.7.1

    Plugin Author RobertHarm

    (@harmr)

    loadtime should be affected by adding this parameter – concerning cross browser issues: please also report this to the developer of the player – perhaps they have a clue…it would be the thing I would look at first…

    Plugin Author RobertHarm

    (@harmr)

    are you using a mac with not an intel processor? other users reported similar problem with other flash apps and this constellation

    No, its PC and Safari. Thanks, I’m to contact the developer of the flash player once again.

    Hello again,
    sorry for taking up your time Robert, but these may be of some help to those having the same problems with the embedded flash content too. I’ve contacted the developers of the player, and they were really supportive. After an hour or so of looking, tweaking, etc., they came to the conclusion that it’s very likely to have something to do with the MapsMarker css. The indirect proof is that this strange behaviour became evident only after I switched to 2.7.1 version – but not before. This is not to say the plugin is bad or whatever – it’s brilliant no matter what, and I do hope that this annoying bug could be fixed one day.

    Plugin Author RobertHarm

    (@harmr)

    Hi,
    thats bad to hear – is there a chance to switch to another flash player? Just to test this out. If I find time, I will take a look into this again.
    regards,
    Robert

    Plugin Author RobertHarm

    (@harmr)

    Hi,
    I opened the map on Opera and flash player showed up. Bug already solved on your site?
    regards,
    Robert

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Plugin: Leaflet Maps Marker] Flash player is not showing up (FF and Safari only)’ is closed to new replies.