WordPress.org

Support

Support » Plugins and Hacks » Lazy Load » [Plugin: Lazy Load] Spaces in image urls: thumbs not loaded

[Plugin: Lazy Load] Spaces in image urls: thumbs not loaded

  • Hi,

    I’m using Lazy Load and it works like a charm, only when my client uploaded an image with a space in the filename… it breaks (no image showed)

    I get:
    <img width="100" height="75" 002.jpg"="" src="[...]/<strong>thumbs_Poefff</strong>" style="display: block;" data-lazy-loaded="true">

    iso
    <img width="100" height="75" src="[...]/<strong>thumbs_Poefff 002.jpg</strong>" style="display: block;" data-lazy-loaded="true">

    any idea how to handle this?
    can I prevent users uploading images with spaces in the filenames?

    thx for any suggestion at all (except for educating clients, believe me: i try 😉

    http://wordpress.org/extend/plugins/lazy-load/

Viewing 2 replies - 1 through 2 (of 2 total)
  • OK, sorry: is a next gen gallery issue: images added through the media library get a nice hyphen for each space on upload, but next gen images keep their spaces..

    the plugin checks explicitly for a space as the end of the src attribute (src ends with ‘, “, space or closing img tag).

    i would suggest to change this: i think spaces in img url’s appear more frequent than non-quoted attributes: the first is user dependent, the latter the responsability of the theme developer. OK, nextgen is a plugin, but a user can also embed an image from a different source than WordPress.

    but probably there are other arguments 😉

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Lazy Load] Spaces in image urls: thumbs not loaded’ is closed to new replies.
Skip to toolbar