Support » Plugin: Google Maps Plugin by Intergeo » Plugin keeps “forgetting” an entered API key

  • Resolved Rafael

    (@jordh)


    Hello,

    I have an issue with the plugin handling my Google Maps API key. Every now and then (several times a day), the plugin “forgets” the key and shows an empty field on the settings page. All maps then display the “for development purposes only” text.

    When I re-enter the API key and refresh the pages, it works for some time before reverting back to the no-key state. I couldn’t find a specific trigger for this.

    Disabling any potentially interfering plugins (e.g. W3 Total Cache) did not solve the issue. I have also turned on debugging, but the logs show no errors or warning related to Intergeo Maps or the database in general.

    Any pointers would be appreciated.

    Regards,
    Rafael

Viewing 2 replies - 1 through 2 (of 2 total)
  • In today’s logs, I found these two lines:

    [29-Jan-2019 06:54:54 UTC] PHP Warning:  array_merge(): Argument #1 is not an array in [...]/wp-content/plugins/intergeo-maps/vendor/codeinwp/themeisle-sdk/class-themeisle-sdk-widget-dashboard-blog.php on line 375
    [29-Jan-2019 06:54:54 UTC] PHP Warning:  Invalid argument supplied for foreach() in [...]/wp-content/plugins/intergeo-maps/vendor/codeinwp/themeisle-sdk/class-themeisle-sdk-widget-dashboard-blog.php on line 376

    Maybe this is related to the issue.

    Plugin Author Themeisle

    (@themeisle)

    Hi @jordh,

    Thank you for contacting us. I’m sorry for my delayed reply. This issue might occur because of a conflict with another plugin/theme that uses class SDK for notifications.

    Can you tell us what theme do you use and if you installed any recent plugin currently?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Plugin keeps “forgetting” an entered API key’ is closed to new replies.