Support » Plugin: JW Player for Flash & HTML5 Video » [Plugin: JW Player Plugin for WordPress] Automatic update to 1.20 = failed

Viewing 15 replies - 1 through 15 (of 35 total)
  • And if uploaded manually. I got this error message:

    Warning: opendir(/home/clients/client0/web39/web/wordpress/wp-content/uploads/jw-player-plugin-for-wordpress/configs) [function.opendir]: failed to open dir: No such file or directory in /home/clients/client0/web39/web/wordpress/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 158

    wp-content/uploads/jw-player-plugin-for-wordpress/configs is wrong. should be the folder “player” at the end.

    damn I have to downgrade :/

    there are other problems… It’s totally bugged :s hurry up! :s :s

    Plugin Author JW Player

    (@longtail-video)

    @thibotus01,

    We are aware of the issues and are investigating. I’ll keep you updated with what I find.

    So when you said you tried to update automatically you are referring to the automatic update of the player or the plugin?

    Thanks.

    Great! thanks

    It’s via the update of the plugin…

    del this message.

    Plugin Author JW Player

    (@longtail-video)

    Actually, what OS is your server running on?

    I too am having a massive problem with this plugin upgrade. I too got the same PCLZIP_ERR_BAD_FORMAT (-10) : Invalid archive structure yesterday but since the videos on my blog still worked I ignored it.

    I tried it again today and the upgrade appeared to work fine.

    BUT I can no longer create custom players – all my videos are tiny – there’s no reference to the custom players I created in the past and now when I do attempt to create one I get:

    Warning: opendir(/home/neilperryman/whofix.net/wp-content/uploads/jw-player-plugin-for-wordpress/configs) [function.opendir]: failed to open dir: No such file or directory in /home/neilperryman/whofix.net/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 158

    Warning: readdir(): supplied argument is not a valid Directory resource in /home/neilperryman/whofix.net/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 160

    Warning: closedir(): supplied argument is not a valid Directory resource in /home/neilperryman/whofix.net/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 165

    I can’t even delete the plugin in an attempt to begin again.

    Any ideas?

    Neil

    It’s on Linux – Debian Lenny.

    I got all the same problem that tachyontv has

    Is there any way for me to downgrade until this is sorted? I can’t seem to delete it from the wordpress panel…

    nope, you have to delete it from FTP, and restore your backup 🙂

    Plugin Author JW Player

    (@longtail-video)

    Just to give you guys an update.

    I’ve checked in an update to the plugin which should be picked up by the WordPress packager and be made available soon. This should hopefully address the permission issues when you perform the plugin upgrade.

    I apologize for the inconvenience this has caused. The number of WordPress configurations in the wild can make it difficult to test to say the least.

    If there are any more problems just let me know.

    Thanks.

    Hi still having the same problem with the lastest update – first of all it would’t work with this error – PCLZIP_ERR_BAD_FORMAT (-10) : Invalid archive structure

    Then, on the third attempt it said it installed.

    However, if I attempt to create a custom player it claims to have saved it but it doesn’t appear under the manage players options. The top of my dashboard is also filled with code such as:

    Warning: fopen(/home/neilperryman/whofix.net/wp-content/uploads/jw-player-plugin-for-wordpress/configs/Tachyon TV.xml) [function.fopen]: failed to open stream: No such file or directory in /home/neilperryman/whofix.net/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 87

    Warning: fwrite(): supplied argument is not a valid stream resource in /home/neilperryman/whofix.net/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 88

    Warning: fclose(): supplied argument is not a valid stream resource in /home/neilperryman/whofix.net/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 89

    Warning: opendir(/home/neilperryman/whofix.net/wp-content/uploads/jw-player-plugin-for-wordpress/configs) [function.opendir]: failed to open dir: No such file or directory in /home/neilperryman/whofix.net/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 158

    Warning: readdir(): supplied argument is not a valid Directory resource in /home/neilperryman/whofix.net/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 160

    Warning: closedir(): supplied argument is not a valid Directory resource in /home/neilperryman/whofix.net/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 165

    Warning: opendir(/home/neilperryman/whofix.net/wp-content/uploads/jw-player-plugin-for-wordpress/configs) [function.opendir]: failed to open dir: No such file or directory in /home/neilperryman/whofix.net/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 158

    Warning: readdir(): supplied argument is not a valid Directory resource in /home/neilperryman/whofix.net/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 160

    Warning: closedir(): supplied argument is not a valid Directory resource in /home/neilperryman/whofix.net/wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php on line 165

    Plugin Author JW Player

    (@longtail-video)

    Alright, looks like I may need to loosen the permissions even further which makes me a little uncomfortable. Its working correctly on my Ubuntu VM so there must be something different about the permissions available to your WordPress install.

    I’ll investigate further this evening and see what I can do.

    If you can poke around your server, you should be able to see if the following directory was created:

    /home/neilperryman/whofix.net/wp-content/uploads/jw-player-plugin-for-wordpress/configs

    As for the unzip error I’m not sure what I can do about that on my end. The archive is being built by WordPress’ automated packing system so that is outside of my control. I’m guessing you don’t have any issues with updating other plugins automatically?

    Doing a bit of research it seems like it could either be a memory issue or something particular to your WordPress install. What version of WordPress are you running?

    Thanks for bearing with me.

    1.2.0 to 1.2.2

    same as thibotus01

    I don’t have any problem with updating other plugins. First time I got the “invalid archive structure”.
    I’m on 3.0.1
    My server is using SuEXEC, so I don’t have to manage permissions.

    EDIT : looks like the last update 1.2.2 works properly on my server… No error.

    EDIT2: but still buggy… If I edit the dimensions (or other any options) of a player, it lose the plugins I checked.

Viewing 15 replies - 1 through 15 (of 35 total)
  • The topic ‘[Plugin: JW Player Plugin for WordPress] Automatic update to 1.20 = failed’ is closed to new replies.