Support » Plugin: JW Player for Flash & HTML5 Video » [Plugin: JW Player for WordPress – Flash & HTML5 Video Player] Videos not working in Firefox

  • I’m not sure when this started, but it was probably in the last couple of weeks.

    For some reason, I can’t see my videos in the FireFox (version 7.0.1) browser anymore. Some of my customers also cannot see the videos in Firefox and they tell me that they can’t see them using Chrome either.

    However, we can see the videos if we use Internet Explorer (version 8.0.6001.18702)

    What’s even more odd is that other customers can see my videos and they appear to be using the same version of Firefox I’m using and they have the same version of the Flash Player.

    I’m currently using WordPress version 3.2.1. I have the JW Player Plugin for WordPress (version 1.5.2). And, I am also using a commercially licensed player (version 5.8.2011)

    I have checked my version of Flash Player and it is version 11.0.1.152, which I believe is the most current version.

    I could sure use some help figuring out why some people can see my videos in Firefox and and others, including myself, can’t see them.

    Thanks!

    http://wordpress.org/extend/plugins/jw-player-plugin-for-wordpress/

Viewing 15 replies - 1 through 15 (of 42 total)
  • Plugin Author JW Player

    (@longtail-video)

    Hi Curt,

    Sorry to hear you’re having difficulty.

    Can you provide a link to a page where a video isn’t playing for you in Firefox? I’ll take a look into it.

    Thanks.

    Ah, I forgot that part:)

    The website I’m having trouble with is http://www.prestatraining.com.

    I also want to mention that I use the JW Player on other websites as well. On those websites, I have not updated to the most recent version of the JW Player and I’m not having issues seeing those videos. They all work as they should.

    I’m guessing that indicates there is some sort compatibility issue with the most recent version of the JW Player and FireFox/Chrome?

    However, I don’t have a clue why some people with the exact same version of FireFox that I have can see the videos and I cannot?

    I should point out that a page you will want to go to to see the video player that is not working for me is: http://www.prestatraining.com/display-categories-products-specific-groups/.

    I was working with another LongTail rep on Friday and he said he could see the page I pointed out to him. He even sent screen shots, so I know he could see it. I definitely could not see what he saw, though.

    This is issue I and some others are having is consistent with any of the other pages where I used a custom size/settings player. None of those pages show up to me. Where I changed some of the pages back to the default player, those pages all now work.

    What do you think?

    Plugin Author JW Player

    (@longtail-video)

    Hi Curt,

    Well this became a bit harder to resolve since the player displays correctly for me in Firefox 7.0.1 using Flash 11.0.1.152. I’m not seeing any errors on the page either.

    Also, do you have Firebug installed? If so, do you see any errors in the log?

    In any case I think the next step is to identify any differences you have in your copy of Firefox. Have you made any modifications to it or installed any addons? I think the first step is for you to try disabling any Firefox addons you have since they may be interfering with how the page is loading.

    Thanks.

    Thanks for the reply and suggestion.

    I did just turn off ALL of my addons and there was no improvement. Then I turned off ALL the plugins and that solved the problem. I haven’t narrowed down which plugin it is yet, but I’ll post again when I figure that out.

    I appreciate the help!

    The one plugin that is causing the problem is: Shockwave Flash 11.0.1.152.

    I’m not sure what problems I’ll have now that I’ve disabled this plugin. What are your thoughts?

    I have a fix.

    The XML document it creates for the configuration is not properly formed.

    wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php
    Line 104
    This:
    fwrite($xml_handle, “<config>\n” . $xml_string . “</config>”);

    To:
    fwrite($xml_handle, “<?xml version=\”1.0\” encoding=\”UTF-8\” ?>\n<config>\n” . $xml_string . “</config>”);

    Remember to resave you custom (or default) player in the settings panel.

    Plugin Author JW Player

    (@longtail-video)

    @bigorangemachine,

    This is certainly something that needs to be fixed, although I’m not sure how it’s related to Curt’s issue since it works properly for me in Firefox. Were you experiencing the same issue as Curt?

    @curt,

    Did you try @bigorangemachine suggestion?

    Thanks.

    Not tried @bigorangemachine XML fix but thought I let you know that, it is not just @curt, we also have the same problem with Firefox.

    Other browsers seem fine – Safari, Chrome, Internet Explorer.

    The problem, which started a few weeks ago, is on both PC and Mac. Might be connected to us now using flv and mov files which we just started doing. Previously we could not get HTML5 to work. Firefox now knowns when the files are not correct but when it is correct you just get a spinning wheel.

    Here’s a video example:-

    The link to the video went missing on my post.

    Hopefully here it is:-http://filmreviewonline.com/2011/11/06/twilight-saga-breaking-dawn-hand-foot-print-ceremony/

    Plugin Author JW Player

    (@longtail-video)

    @stephenpayne,

    In the flash case the file twilightsagahands.flv doesn’t seem to actually be an FLV file. This may be part of the issue you’re seeing.

    In the HTML 5 case, you’re specifying an MOV file for the fallback. Firefox doesn’t not support MOV files in HTML5 mode. You would need to use an OGG Theora or WEBM file.

    If you have any other questions just let me know.

    Thanks.

    Thanks that is helpful. Our intention was to supply MOV files for iOS devices.

    The twilightsagahands.flv has been made the same way as before so although it is a cheat, as you correctly worked out, I suspect it is not the problem. It worked ok for Firefox then.

    Looks like Firefox is trying to use the HTML5 file – which does of course work fine for the iPad etc that it was intended for. Is there a way to get Firefox to use the flash file only while continuing to supply MOV files for the iPad/iPhone?

    In the long run we would like to supply the video via streaming – can you point me to somewhere so I can work out how to do that? (Although, I believe, LongTail currently can not cope with MOV via this method.)

    Plugin Author JW Player

    (@longtail-video)

    Hi Stephen,

    Currently there’s no mechanism for browser specific configurations in the JW Player, however this is on the roadmap. One workaround is to use the levels block (http://www.longtailvideo.com/support/jw-player/jw-player-for-flash-v5/15995/jw-embedder-reference-guide#levels) which lets you specify different encodings. However, the shortcode in the WordPress plugin doesn’t support this yet.

    For now, I would focus on getting it to work for the iPad. I imagine most Firefox users will be running Flash so the flash mode configuration should handle Firefox in most cases. I’m still concerned about the twilightsagahands.flv. What format is it actually?

    In regards to streaming, do you mean RTMP streaming? If so, support for MOV (h264 encoded) is largely up to the server. If the server can stream the file via RTMP the JW Player will handle it.

    Thanks.

    @bigorangemachine,
    This is certainly something that needs to be fixed, although I’m not sure how it’s related to Curt’s issue since it works properly for me in Firefox. Were you experiencing the same issue as Curt?

    @LongTail Video,
    I had an issue where firefox wasn’t loading the videos. I used a default player and it worked. I created a custom style and the videos wouldn’t load. I use to have a similar issue with older versions of IE and ajax.

    @LongTail Video,
    Thanks – on our tests for iPad/iPhone it is working so hopefully no problems there.

    Regarding Firefox I too was assuming it would be running the flash file.

    So here are the details of that. The flash file is a h264/AAC MOV file with the .mov overtyped to .flv (which I understood was an accepted cheat). These have been produced from iMovie and more recently Final Cut Pro but none of the files are now playing with Firefox. (and this includes examples where we supplied no HTML5 options).

    Yes did mean RTMP streaming in future. Some of the Movie studios are starting to ask for that. We have just started to use Amazon’s AWS services but not studied what is available regarding video streaming.

Viewing 15 replies - 1 through 15 (of 42 total)
  • The topic ‘[Plugin: JW Player for WordPress – Flash & HTML5 Video Player] Videos not working in Firefox’ is closed to new replies.