Support » Plugin: JW Player for Flash & HTML5 Video » [Plugin: JW Player for WordPress – Flash & HTML5 Video Player] Version Unknown, player not wor

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author JW Player

    (@longtail-video)

    @alex95sv

    Can you provide a link to where it’s not embedding correctly?

    Thanks.

    Yes, for example here: http://tvseriesbg.com/2012/02/02/the-river-s01e01-02-v-gledayte-predpremierata-onlayn/ it doesnt show at all, but I have [jwplayer mediaid=”20324″] … the download link is separately

    Plugin Author JW Player

    (@longtail-video)

    @alex95sv,

    Thanks for providing the link. It looks like it’s trying to embed with SWFObject despite the presence of the JWEmbedder on the page. Out of curiosity, does it say “Current Player: Version Unknown” in your JW Player admin section?

    Thanks.

    Yes it does… what should I do about it? :/

    Plugin Author JW Player

    (@longtail-video)

    @alex95sv,

    There are definitely some workarounds so don’t worry about that.

    How did you install the player on your site? Did you use the automated install, the upload, or did you FTP it to your site?

    Thanks.

    I used the automated install (but it didnt worked from the first time, I had to try two or three times, some ZIP contents error(?) )… I’ve also tried to reinstall the player from the settings, but still… 🙁

    Plugin Author JW Player

    (@longtail-video)

    @alex95sv,

    There are two possible workarounds. One involves changing one of the php plugin files. The other is a small update to the database.

    Which would you feel comfortable with?

    Keep in mind I’m working an update to address this issue.

    Thanks.

    Well, I’m fine with both of those ways. But let’s try first to change the php files 🙂

    Plugin Author JW Player

    (@longtail-video)

    @alex95sv,

    Sorry for the delay. Just trying to get caught up because of the long weekend.

    The code change will require you to modify the jw-player-plugin-for-wordpress/media/JWShortcode.php file.

    On lines 242 and 244 change $version && $embedder to just $embedder.

    That should do the trick. If not, just let me know.

    Thanks.

    I did it, but it doesnt seem to work… maybe i did it wrong? 😀
    Here’s my edited lines:
    242
    $swf = LongTailFramework::generateSWFObject($embedder, get_option(LONGTAIL_KEY . "player_location"));

    244

    $swf = LongTailFramework::generateSWFObject($embedder);

    Is this right?

    P.s. sorry for the noob questions… :/

    Plugin Author JW Player

    (@longtail-video)

    The two lines should look like the following. I apologize for not being clearer in my description.

    $swf = LongTailFramework::generateSWFObject($atts, $embedder, get_option(LONGTAIL_KEY . "player_location"));
    $swf = LongTailFramework::generateSWFObject($atts, $embedder);

    Thanks.

    Thank you very much! That fixed it! :))

    Thanks again for the wonderful support! ^^

    Plugin Author JW Player

    (@longtail-video)

    @alex95sv,

    Glad it worked for you. This change will be already made in future versions of the plugin so you shouldn’t have any issues with upgrading.

    Thanks.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: JW Player for WordPress – Flash & HTML5 Video Player] Version Unknown, player not wor’ is closed to new replies.