Support » Plugins and Hacks » [Plugin: JW Player for WordPress – Flash & HTML5 Video Player] Getting the default HTML5 to wo

[Plugin: JW Player for WordPress – Flash & HTML5 Video Player] Getting the default HTML5 to wo

  • I’m just trying to get the HTML5 skin to be the default player. I’ve checked the correct HTML5 option with the settings menu in admin panel but I keep getting the default skin and not the skin I’ve downloaded. If I switch to Flash as the default the skin loads fine. I don’t think I’ve got my file locations correct, this is what my template tag looks like:

    <?php echo jwplayer_tag_callback('[jwplayer config="custom player" sking="http://localhost:8888/kettlesyard_wordpress/wp-content/plugins/jw-player-plugin-for-wordpress/kettlesyard/kettlesyard.xml" playlistid="172"]'); ?>

    Is this right? Do I have to do anything else to get it working?


Viewing 6 replies - 1 through 6 (of 6 total)
  • Can anybody help me out?

    Plugin Author JW Player



    Can you provide a link to your page so I can see what’s happening? Are you seeing any errors in the browser console or firebug?


    Unfortunately its not live currently as i’m working locally. I’ve checked the browser console but can’t see anything obvious but not sure really where to look for errors. I’m using Chrome.

    This is what my structure looks like: http://f.cl.ly/items/1m1q233V1N1t030Q1b1y/Screen%20Shot%202012-03-28%20at%2015.24.47.png

    Plugin Author JW Player



    Have you tried pointing to the .zip file instead? The player will automatically load the XML file if it’s running in HTML5 mode.


    Well I’ve selected my theme name from the dropdown menu in the settings pane in wp-admin and enabled HTML5 mode (also in wp-admin) if thats what you mean?

    I have noticed though that single quotes are being outputted in the src, see below:

    <script type='text/javascript' src='http://localhost:8888/kettlesyard_wordpress/wp-content/uploads/jw-player-plugin-for-wordpress/player/jwplayer.js?ver=3.3.2'></script>
    <div id="jwplayer-1-div" class="custom player">
    <div id="jwplayer-1"></div>
    <script type='text/javascript'>jwplayer('jwplayer-1').setup({"flashplayer":"http:\/\/localhost:8888\/kettlesyard_wordpress\/wp-content\/uploads\/jw-player-plugin-for-wordpress\/player\/player.swf","width":"210","height":"170","controlbar":"over","dock":"false","autostart":"false","icons":"true","playlist.position":"none","playlistsize":"180","repeat":"none","shuffle":"true","bufferlength":"1","smoothing":"true","stretching":"uniform","wmode":"opaque","mute":"false","volume":"90","skin":"http:\/\/localhost:8888\/kettlesyard_wordpress\/wp-content\/plugins\/jw-player-plugin-for-wordpress\/skins\/kettlesyard\/kettlesyard.zip","controlbar.idlehide":"true","backcolor":"#ffffff","file":"","modes":[{"type":"html5","config":{"streamer":"","provider":""}},{"type":"flash","src":"http:\/\/localhost:8888\/kettlesyard_wordpress\/wp-content\/uploads\/jw-player-plugin-for-wordpress\/player\/player.swf"},{"type":"download","config":{"streamer":"","provider":""}}],"playlist":[{"title":"MYKY12T1X5G7M - Duncan Robinson","creator":"","author":"","date":"2012-03-29 10:50:00","levels":[{"file":"http:\/\/localhost:8888\/kettlesyard_wordpress\/wp-content\/uploads\/2012\/03\/MYKY12T1X5G7M.mp3"},{"file":"http:\/\/localhost:8888\/kettlesyard_wordpress\/wp-content\/uploads\/2012\/03\/MYKY12T1X5G7M.mp3"},{"file":"http:\/\/localhost:8888\/kettlesyard_wordpress\/?p=281"}],"image":"http:\/\/localhost:8888\/kettlesyard_wordpress\/wp-content\/uploads\/2012\/03\/houseasartw_thumb.jpg","description":"","mediaid":"186","id":"186"}]});</script>

    Is this correct?

    Have gone a completely different route now seeing as responses to this thread have been slow.

    Now going completely HTML5 & gone independent of any plugins using clean and semantic code.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: JW Player for WordPress – Flash & HTML5 Video Player] Getting the default HTML5 to wo’ is closed to new replies.