WordPress.org

Forums

JW Player for Flash & HTML5 Video
[Plugin: JW Player for WordPress – Flash & HTML5 Video Player] Videos not working in Firefox (43 posts)

  1. Curt Donohue
    Member
    Posted 3 years ago #

    I'm not sure when this started, but it was probably in the last couple of weeks.

    For some reason, I can't see my videos in the FireFox (version 7.0.1) browser anymore. Some of my customers also cannot see the videos in Firefox and they tell me that they can't see them using Chrome either.

    However, we can see the videos if we use Internet Explorer (version 8.0.6001.18702)

    What's even more odd is that other customers can see my videos and they appear to be using the same version of Firefox I'm using and they have the same version of the Flash Player.

    I'm currently using WordPress version 3.2.1. I have the JW Player Plugin for WordPress (version 1.5.2). And, I am also using a commercially licensed player (version 5.8.2011)

    I have checked my version of Flash Player and it is version 11.0.1.152, which I believe is the most current version.

    I could sure use some help figuring out why some people can see my videos in Firefox and and others, including myself, can't see them.

    Thanks!

    http://wordpress.org/extend/plugins/jw-player-plugin-for-wordpress/

  2. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Curt,

    Sorry to hear you're having difficulty.

    Can you provide a link to a page where a video isn't playing for you in Firefox? I'll take a look into it.

    Thanks.

  3. Curt Donohue
    Member
    Posted 3 years ago #

    Ah, I forgot that part:)

    The website I'm having trouble with is http://www.prestatraining.com.

    I also want to mention that I use the JW Player on other websites as well. On those websites, I have not updated to the most recent version of the JW Player and I'm not having issues seeing those videos. They all work as they should.

    I'm guessing that indicates there is some sort compatibility issue with the most recent version of the JW Player and FireFox/Chrome?

    However, I don't have a clue why some people with the exact same version of FireFox that I have can see the videos and I cannot?

  4. Curt Donohue
    Member
    Posted 3 years ago #

    I should point out that a page you will want to go to to see the video player that is not working for me is: http://www.prestatraining.com/display-categories-products-specific-groups/.

    I was working with another LongTail rep on Friday and he said he could see the page I pointed out to him. He even sent screen shots, so I know he could see it. I definitely could not see what he saw, though.

    This is issue I and some others are having is consistent with any of the other pages where I used a custom size/settings player. None of those pages show up to me. Where I changed some of the pages back to the default player, those pages all now work.

    What do you think?

  5. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Curt,

    Well this became a bit harder to resolve since the player displays correctly for me in Firefox 7.0.1 using Flash 11.0.1.152. I'm not seeing any errors on the page either.

    Also, do you have Firebug installed? If so, do you see any errors in the log?

    In any case I think the next step is to identify any differences you have in your copy of Firefox. Have you made any modifications to it or installed any addons? I think the first step is for you to try disabling any Firefox addons you have since they may be interfering with how the page is loading.

    Thanks.

  6. Curt Donohue
    Member
    Posted 3 years ago #

    Thanks for the reply and suggestion.

    I did just turn off ALL of my addons and there was no improvement. Then I turned off ALL the plugins and that solved the problem. I haven't narrowed down which plugin it is yet, but I'll post again when I figure that out.

    I appreciate the help!

  7. Curt Donohue
    Member
    Posted 3 years ago #

    The one plugin that is causing the problem is: Shockwave Flash 11.0.1.152.

    I'm not sure what problems I'll have now that I've disabled this plugin. What are your thoughts?

  8. bigorangemachine
    Member
    Posted 3 years ago #

    I have a fix.

    The XML document it creates for the configuration is not properly formed.

    wp-content/plugins/jw-player-plugin-for-wordpress/framework/LongTailFramework.php
    Line 104
    This:
    fwrite($xml_handle, "<config>\n" . $xml_string . "</config>");

    To:
    fwrite($xml_handle, "<?xml version=\"1.0\" encoding=\"UTF-8\" ?>\n<config>\n" . $xml_string . "</config>");

    Remember to resave you custom (or default) player in the settings panel.

  9. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    @bigorangemachine,

    This is certainly something that needs to be fixed, although I'm not sure how it's related to Curt's issue since it works properly for me in Firefox. Were you experiencing the same issue as Curt?

    @Curt,

    Did you try @bigorangemachine suggestion?

    Thanks.

  10. StephenPayne
    Member
    Posted 3 years ago #

    Not tried @bigorangemachine XML fix but thought I let you know that, it is not just @Curt, we also have the same problem with Firefox.

    Other browsers seem fine - Safari, Chrome, Internet Explorer.

    The problem, which started a few weeks ago, is on both PC and Mac. Might be connected to us now using flv and mov files which we just started doing. Previously we could not get HTML5 to work. Firefox now knowns when the files are not correct but when it is correct you just get a spinning wheel.

    Here's a video example:-

  11. StephenPayne
    Member
    Posted 3 years ago #

    The link to the video went missing on my post.

    Hopefully here it is:-http://filmreviewonline.com/2011/11/06/twilight-saga-breaking-dawn-hand-foot-print-ceremony/

  12. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    @StephenPayne,

    In the flash case the file twilightsagahands.flv doesn't seem to actually be an FLV file. This may be part of the issue you're seeing.

    In the HTML 5 case, you're specifying an MOV file for the fallback. Firefox doesn't not support MOV files in HTML5 mode. You would need to use an OGG Theora or WEBM file.

    If you have any other questions just let me know.

    Thanks.

  13. StephenPayne
    Member
    Posted 3 years ago #

    Thanks that is helpful. Our intention was to supply MOV files for iOS devices.

    The twilightsagahands.flv has been made the same way as before so although it is a cheat, as you correctly worked out, I suspect it is not the problem. It worked ok for Firefox then.

    Looks like Firefox is trying to use the HTML5 file - which does of course work fine for the iPad etc that it was intended for. Is there a way to get Firefox to use the flash file only while continuing to supply MOV files for the iPad/iPhone?

    In the long run we would like to supply the video via streaming - can you point me to somewhere so I can work out how to do that? (Although, I believe, LongTail currently can not cope with MOV via this method.)

  14. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Stephen,

    Currently there's no mechanism for browser specific configurations in the JW Player, however this is on the roadmap. One workaround is to use the levels block (http://www.longtailvideo.com/support/jw-player/jw-player-for-flash-v5/15995/jw-embedder-reference-guide#levels) which lets you specify different encodings. However, the shortcode in the WordPress plugin doesn't support this yet.

    For now, I would focus on getting it to work for the iPad. I imagine most Firefox users will be running Flash so the flash mode configuration should handle Firefox in most cases. I'm still concerned about the twilightsagahands.flv. What format is it actually?

    In regards to streaming, do you mean RTMP streaming? If so, support for MOV (h264 encoded) is largely up to the server. If the server can stream the file via RTMP the JW Player will handle it.

    Thanks.

  15. bigorangemachine
    Member
    Posted 3 years ago #

    @bigorangemachine,
    This is certainly something that needs to be fixed, although I'm not sure how it's related to Curt's issue since it works properly for me in Firefox. Were you experiencing the same issue as Curt?

    @LongTail Video,
    I had an issue where firefox wasn't loading the videos. I used a default player and it worked. I created a custom style and the videos wouldn't load. I use to have a similar issue with older versions of IE and ajax.

  16. StephenPayne
    Member
    Posted 3 years ago #

    @LongTail Video,
    Thanks - on our tests for iPad/iPhone it is working so hopefully no problems there.

    Regarding Firefox I too was assuming it would be running the flash file.

    So here are the details of that. The flash file is a h264/AAC MOV file with the .mov overtyped to .flv (which I understood was an accepted cheat). These have been produced from iMovie and more recently Final Cut Pro but none of the files are now playing with Firefox. (and this includes examples where we supplied no HTML5 options).

    Yes did mean RTMP streaming in future. Some of the Movie studios are starting to ask for that. We have just started to use Amazon's AWS services but not studied what is available regarding video streaming.

  17. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    @bigorangemachine

    I will definitely be adding in the xml header in the next version. Are there any other issues you need me to look into?

    @StephenPayne,

    So I played around with it a bit more. I believe the issue in Firefox is related to the Content-Type or mimetype the ".flv" file is being served with. Currently it is set to "text/plain." If the file has the the video/quicktime or video/x-flv mimetype it plays correctly in Firefox. Firefox seems to be picky about the mimetype.

    AWS should be fine for streaming. Cloudfront works nicely with the JW Player.

    Thanks.

  18. StephenPayne
    Member
    Posted 3 years ago #

    I believe the issue in Firefox is related to the Content-Type or mimetype the ".flv" file is being served with. Currently it is set to "text/plain." If the file has the the video/quicktime or video/x-flv mimetype it plays correctly in Firefox. Firefox seems to be picky about the mimetype.

    @LongTail Video,
    Only partly following this. The files are produced though "share" via quicktime and all the advice I read says over-typing .mov to .flv is correct.

    Here is a alternative link to check with files produced this time with iMovie. Again it was working but not now.
    http://filmreviewonline.com/2011/07/17/salvation-boulevard-trailer-clips-image-gallery-and-release-date/

    We now using the current version FinalCutPro but again there is now direct way to get .flv files.

  19. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Stephen,

    This issue doesn't actually have anything to do with your export of the video from (iMovie, Final Cut Pro, etc.). It's an issue of how the file is being served to the browser. The mimetype tells the browser what kind of file it is, whether it be an image, a video, css, etc.

    In this case Firefox is being told the file is text. Normally this shouldn't cause an issue but for some reason Firefox is being picky about it. Have you made any configuration changes on your server the last little while?

    Also, why are you changing the extension to flv? As long as it's h264 the player can play .mov files without issue in Flash mode.

    Thanks.

  20. StephenPayne
    Member
    Posted 3 years ago #

    @LongTail Video,
    I was under the (mis-)understanding that the file need to be a flash file to be more universally playable. If .mov files work just the same that would simplify things and be good news. Thanks.

    We have recently started using http://www.cloudflare.com and also AWS. (via W3 Total Cache WordPress plugin). The actual server has remained the same. Would any of this have any effect on the server configuration your thinking about?

  21. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    @Stephen,

    Yes, this sounds like it could potentially be the issue.

    Is the twilightsagahands.flv file located on AWS?

  22. StephenPayne
    Member
    Posted 3 years ago #

    @LongTail Video,
    On the W3 Total Cache WordPress plugin I have ticked CDN Enable and given the CDN type as Amazon CloudFront. In the CDN details most of the boxes are ticked for hosting although video files are not specifically mentioned. I guess the answer is yes...

    Is there something I can adjust to make FireFox happy?

  23. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    @Stephen,

    On a closer look, it seems the file is being loaded from your WordPress uploads directory.

    Do you have access to your AWS bucket to see if the file is there?
    If it's not on S3 how are you uploading the video file to your WordPress site?

    I think we're close to getting this fixed!

    Thanks.

  24. StephenPayne
    Member
    Posted 3 years ago #

    @LongTail Video,
    Not sure what an AWS bucket is - I check it out - but we don't use amazon's S3. The site is based on inmotionhosting VPS as it has for sometime now.

  25. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    Ok, so it's likely not on AWS.

    How are you uploading your video files to your site? Using FTP? Or through WordPress?

  26. StephenPayne
    Member
    Posted 3 years ago #

    @LongTail Video,
    Files uploaded though WordPress

  27. holospirit
    Member
    Posted 3 years ago #

    i have the same issue since 1.43 - firefox (flash: WIN 11,0,1,152) doesn't play anything; android gives a "file not found" error. all other browsers working (ie flash: WIN 11,0,1,129).
    tryed bigorangemachine's framework-hack but no success.
    http://holospirit.eu/blog/der-goettliche-grillen-chor/

    by the way: the streamer and flashvars in adv. settings aren't saved anymore. also they are gone after an update of jwplayer.

    regards,
    thomas

  28. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry for the delay guys. I was on vacation and didn't have Internet access.

    @StephenPayne,

    Hmm, this is now less obvious. What browser are you using to upload the files? Have you changed the browser you are using recently?

    @holospirit,

    I checked the link you provided in Firefox. It looks like a YouTube video which seems to be working for me in my copy of FireFox using the same version of Flash. Do you have any other links that aren't working as expected?

    I'll take a look into the advanced settings issues. What do you mean they are gone after an update of the jwplayer? Did they return to the default values?

    Thanks.

  29. StephenPayne
    Member
    Posted 3 years ago #

    @LongTail Video,
    Files uploaded though WordPress with Firefox as usual. I have sometimes used Safari.

    I have just done some more checking and it may be more useful to know the playerlist feature does not seem to be working now on older posts. Worked nicely before. Now only one video is showing up in a bigger space regardless of browser. The videos play in Safari (and Chrome) but not Firefox.

    Must admit beginning to think that this is not a stable or useable solution for video with wordpress. I am hoping your be able to regain my trust in LongTail video...

    Example of player list use (now not showing the 4 videos).
    http://filmreviewonline.com/2011/03/27/source-code-trailers-and-release-dates/

  30. holospirit
    Member
    Posted 3 years ago #

    hi longtail,

    the settings for streamer, provider, flashvars aren't shown up, meaning the fields are empty. only streamer shows "http:". the settings seem not to be taken (my old streamer values are "invisible" present, but i can't change them) and the fields are empty when opening them again.

    regarding to "my" firefox-not-showing-bug - i can't show an other link. all youtube-videos didn't work. on all other browsers, they work.

    if found an other "problem": external files (not youtube) seem to run over MY streamer (when using default player it works) - without having it configurated to do so:
    ++false (external file): http://holospirit.eu/blog/haben-wir-einen-freien-willen/
    -> "file":"http://gutenberg.tv.s3.amazonaws.com/flv_low/FS0011_geforscht_100705.mp4" (does http://cdn.holospirit.eu/stream/?file=http://gutenberg.tv.s3.amazonaws.com/flv_low/FS0011_geforscht_100705.mp4&start=0)
    ++true (internal file): http://holospirit.eu/blog/choice-for-the-ego-a-metaphor/
    -> "streamer":"http://cdn.holospirit.eu/stream/","file":"cfte.flv" (does http://cdn.holospirit.eu/stream/?file=cfte.flv&start=0)

    regarding to the empty values in the streamer settings - what can i do? taking the default-player-version seems not to be the optimal solution.

    thanks a lot,
    thomas

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • JW Player for Flash & HTML5 Video
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic