WordPress.org

Support

Support » Plugins and Hacks » [Plugin: jQuery Lightbox] Version 0.16 crashed my site

[Plugin: jQuery Lightbox] Version 0.16 crashed my site

  • I’ve just done the automatic upgrade of the plugin to version 0.16 and it crashed my blog.
    It used to work fine before upgrading to this version.

    Hope you can fix that.

    thanks.

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author Pedro Lamas

    @ei99070

    Seen the problem too, I’ll be checking a solution…

    Please check if it did update (think so) and manually activate!

    Plugin Author Pedro Lamas

    @ei99070

    I’m seeing crashes when updating other plugins… can anybody please confirm if you are having crashes when updating this or other plugin?

    @pedro Lamas,
    jquery-lightbox-balupton-edition disabled my blog.

    After updating my plugins, this php error message appears on my blog.

    Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/scrit2/public_html/blog/wp-content/plugins/jquery-lightbox-balupton-edition/jquery-lightbox.php on line 13

    Plugin Author Pedro Lamas

    @ei99070

    @dahdi, some questions: what version of PHP is your blog using? Where you using the 0.15 version before this update?

    Plugin Author Pedro Lamas

    @ei99070

    @all: it seems that WordPress 3.0.2 update stopped the problems with the plugin, so please update your wordpress version and check back if problems arise! 😉

    Using PHP version 5.2.14
    I believe i was using Lightbox version 0.15 before the update, honestly I do not recall the exact version.

    After upgrading to WP 3.0.2, Lightbox still produces an error

    Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/scrit2/public_html/blog/wp-content/plugins/jquery-lightbox-balupton-edition/jquery-lightbox.php on line 13

    Plugin Author Pedro Lamas

    @ei99070

    Sorry for bothering you with this, but are you truly sure you are using PHP 5? Because that error should not appear in v5, only in v4… 🙁

    Please check this out and see it this helps:

    http://www.vbulletin.com/forum/showthread.php?331795-Parse-error-syntax-error-unexpected-T_STATIC-expecting-T_OLD_FUNCTION-or-T_FUNCTIO

    Pedro!
    YOU ARE NOT BOTHERING ME AT ALL. I had to write that in ALL CAPS to let you know I really appreciate your replies. I went back into my server and made sure the PHP configuration explicitly handled all PHP scripts with version 5 and that solved the problem.

    So, with that said, THANKS! Problem solved.

    Plugin Author Pedro Lamas

    @ei99070

    Great news then!!! Hope everything works out ok now! 🙂

    Pedro,

    I’m also having the same problem. I updated to WordPress 3.0.3, and then updated the jquery-lightbox-balupton-edition plugin, and my blog has completely crashed. I’m getting the following error:

    Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in /home/scrit2/public_html/blog/wp-content/plugins/jquery-lightbox-balupton-edition/jquery-lightbox.php on line 13

    My website is http://www.kalaswire.com. Can you help? I downloaded an old version of the plugin and replaced the files on my server, but the error is still happening. I can’t login to wordpress either.

    Thanks for your help!

    -Heather

    Plugin Author Pedro Lamas

    @ei99070

    @cornfritter182, yout problem is the same: just use PHP5 instead of PHP4 and that will do the trick! 🙂

    Pedro-

    Is there any other way to fix this error? I don’t have access to the host’s web panel and no way of finding out if it’s using PHP4 or 5. This is a client’s website.

    Thanks!

    Plugin Author Pedro Lamas

    @ei99070

    @cornfritter182, you can check the PHP version just by creating a new file and adding the phpinfo() function.

    http://php.net/manual/en/function.phpinfo.php

    You can change the assigned PHP version by changing the php.ini file on your site.

    If nothing of this works, you’ll have to use version 0.14 or previous!

    Pedro- How can I install version 0.14 or previous of the plugin if I can’t access my site’s backend?

    Plugin Author Pedro Lamas

    @ei99070

    You can’t access WordPress administration? Try deleting the “jquery-lightbox-balupton-edition” folder under the plugins wordpress folder!

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Plugin: jQuery Lightbox] Version 0.16 crashed my site’ is closed to new replies.