Support » Plugin: Multiple Themes » [Plugin: jonradio Multiple Themes] Not working

  • Resolved Handoko


    Hello sir. It’s a great concept, unfortunately it’s not working.

    I got these errors when I click the “Save Changes” on the setting page:

    Warning: Invalid argument supplied for foreach() in /home/mysite/public_html/demo1/wp-content/plugins/jonradio-multiple-themes/includes/admin.php on line 173

    Warning: Cannot modify header information – headers already sent by (output started at /home/mysite/public_html/demo1/wp-content/plugins/jonradio-multiple-themes/includes/admin.php:173) in /home/mysite/public_html/demo1/wp-includes/pluggable.php on line 881

    Hope it’s will be fixed soon.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Sorry for the delay, but I don’t get notified of support forum posts about my plugin.

    I just re-tested the plugin doing everything I could think of that executes the line (173) of code. It all works perfectly for me.

    Could you possibly try deleting and reinstalling the plugin? Perhaps the install file was corrupted somehow.

    If that doesn’t solve it, please let me know what version of WordPress you are using, as I have only tested (and stated the plugin will work for) the current Version, 3.4.1.

    Also, were you using Multisite? I support Multisite, and did my tests just now in both regular and Multisite, including Network Activation and single site activation.

    Thanks so much for letting me know, rather than just walking away Angry.



    Hello sir,

    Thanks for your reply. I’m not angry, oppositely I’m glad you want to help. This plugin could be very useful to me.

    I’ve tried to deactivate, delete and install the plugin again, but not luck, still got the same error.

    But something strange:
    – It happened on my site, even I reinstalled the plugin
    – Tried to install on my other website, the errors won’t happen
    – Both the website are being developed under subdomains of a same domain
    – All of them are in the same shared hosting account
    – I disabled all other plugins then installed it, same result

    I’m using the latest WordPress 3.4.1, the websites are regular sites not a multisite. The conclusions of my tests, the issue is not caused by webhosting environment, also not conflict with other plugins.

    What can I do next?

    It is late at night here, so I can only offer one simple test tonight:
    in wp-config.php, change the following statement (about Line 81)
    define(‘WP_DEBUG’, false);
    define(‘WP_DEBUG’, true);

    Please let me know the results and, if they don’t tell me anything, I’ll come up with a way to debug the problem tomorrow morning. The plugin has a simple debug function built-in, but I have to activate it by adding a small bit of php code.

    If the site is “live”, I would suggest changing WP_DEBUG back to “false” quite quickly to avoid possible diagnostic messages being visible to your site visitors.



    The site is live, but still underdevelopment, so I set it private. No visitors, only me.

    After set define(‘WP_DEBUG’, true):

    It got this notice:

    Notice: Undefined index: info in /home/mysite/public_html/demo1/wp-content/plugins/good-old-gallery/inc/forms.php on line 26

    and other similar notices:
    – …/plugins/m-vslider/rslider.php on line 611
    – …/plugins/good-old-gallery/inc/widget.php on line 25
    – …/plugins/good-old-gallery/inc/shortcode.php on line 22
    – …/plugins/good-old-gallery/inc/shortcode.php on line 45

    Do I need to contact the other plugin’s creator about the notices?

    Here is the list of plugins I use:
    – Good Old Gallery
    – jonradio Multiple Themes
    – M-vSlider
    – Portfolio Slideshow
    – Simple Lightbox
    – TheCartPress
    – WP Photo Album Plus
    – Weaver II theme

    Is it anything I can do next?

    Unfortunately, a lot of plugin authors don’t test with debug turned on, so I’m not sure there is much point in reporting the errors to them, assuming the plugins are in working order otherwise.

    To the problem at hand, I don’t see how any of those errors you mention would cause the problem with Multiple Themes.

    Before I send you a modified version of the plugin with a lot of debug code added, I would like to know if Multiple Themes generates any other error messages (with Debug on) BEFORE the error message you originally reported. To reduce the number of error messages, disabling the other plugins during the test would be a good idea, since you said that the Multiple Themes error occurs with all other plugins disabled.

    Sorry to drag this out, but my concern is that an error occurs BEFORE the foreach error displayed and my debug info will be “too late” to tell me anything that will identify the real problem.



    After turning on the debug mode, Multiple Themes didn’t generate any other error/warning, except the 2 previous warnings I mentioned in the first comment.

    How will you send me the modified version? Do you need my email? What should I do next now?

    Please use the contact form on my plugin site to send me your e-mail and I’ll send you the debug version:
    It may take an hour or two to put together for you.

    To conform to Support Forum guidelines, I will be reporting what I find here.



    I’ve just contacted you.

    I have debugged the problem and have released Version 1.1 with the fix, which Handoko is now testing.

    It appeared to be a problem with default PHP warning levels as I could not create the error message in my test environment, even though the situation occurs there, too.



    Hello. I’ve done some tests. I think the problem has fix. But I also found another issue. I’ve just sent you an email. Please check it.

    I have verified Handoko’s problem, which only occurs with WordPress sites hosted in the root, as opposed to a subfolder. I am actively working on the problem and commit to have a new version to address this in the next 6-24 hours.

    There were problems in my test environments that were not identifying certain types of problems, such as the ones Handoko has identified, and I am rapidly working towards correcting that deficiency.

    Version 2.0 has now been released to address a problem with the wp_make_link_relative() that only bothered the selection of individual pages or posts, other than the home page, in WordPress installations to the root with Permalinks enabled. All such problems have been resolved.



    I’ve updated to the version 2.0 and done some tests. So far, everything is working correctly. Thanks jonradio for the update and support.

    jonradio is a nice person. His customer support is great. I’m eager to see if he releases new plugins, and will definitely to use them.

    Handoko Zhang.

    So glad to hear that I finally go it right! [at least so far] I am now working on rebuilding all my test environments to make sure I don’t miss these kind of oversights in the future. From another thread, I’ve discovered that my PHP settings were wrong for testing. Even with WP_DEBUG set to TRUE, I was still missing a lot because display_errors was set to OFF.

    More plugins are on the way, and I presently have 5 in the WordPress plugin directory:

    “I was delighted to find this software – jonradio Multiple Themes, which would appear to do exactly what I was looking for. I installed it successfully and chose the different theme for the forum. However when I went back into the forums page (or any other page for that matter) I am getting the following error:
    Fatal error: Call to a member function wp_rewrite_rules() on a non-object in C:\xampp\htdocs\testdesireland\wp-includes\rewrite.php on line 294″

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Plugin: jonradio Multiple Themes] Not working’ is closed to new replies.