WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Jigoshop] Category image is missing

[Resolved] [Plugin: Jigoshop] Category image is missing

  • Treebeard

    @malawimama

    I added a category and an image for that category under Product Categories, and changed the size of the Catalog Image under Image settings, but it’s not showing up on the frontend.

    I think I’m missing something somwhere in the template but I haven’t changed any of the code that ships with it, only the style divs to match the site.

    When I go to a category page, there’s no main category image even though I uploaded one.

    Any ideas?

    http://wordpress.org/extend/plugins/jigoshop/

Viewing 10 replies - 1 through 10 (of 10 total)
  • ebiker4218

    @ebiker4218

    Can you check your settings ?

    If you have ‘manage stock levels’ (sorry i dont have it open right now but words to that effect)

    JiGoShop will not show if you have nil stock…perhaps it is a related issue ?

    First step is your product showing up…but minus the image ?

    If your product AND image is not showing …then it is likely to do with the settings you have specified.

    ebiker4218

    @ebiker4218

    ..you will also need a product with in that category to be in stock for it to show.

    Treebeard

    @malawimama

    I have 2 products in that category.

    Treebeard

    @malawimama

    I can see the product and the product images, so that’s working fine. And stock management is turned off, I’m just setting up the test site for now. I can see the product thumbnails as well, in the category, but what I’m referring to is the Category Image. When you create a category, you can upload a Category Image as well, to appear above the products on the Category page. That image is not showing up, but it’s a built-in feature, apparently, because it’s right there in Jigoshop > Products > Categories.

    What I’m trying to find though is the php hook to call that Category image. I tried installing 2 basic category image plugins, but they don’t do anything for the Jigoshop pages, since those are custom posts (the code doesn’t work when I add it to the jigoshop theme file) so it has to be a specific line of code for Jigoshop.

    I posted on Jigoshop forums too, but the “Jigoshop Team” replied with a link to purchase premium support so I didn’t get an answer from them. But even though it’s a built in feature in their admin settings, they won’t help me unless I pay for premium support. (I would if the project budget was open ended LOL! but I can’t charge the client for something like that.)

    The above statement that Jigoshop sent you an email asking you to purchase premium support is false. It’s called an auto-responder.
    Every ticket people submit gets one.

    If someone has the time to answer your question, it will be on our forums. We don’t answer it on WordPress.org.

    -Chris

    Treebeard

    @malawimama

    AH, that explains the response email. My apologies. I would never have known it was an autoresponder though, you may want to consider adding that information at the bottom of the email so others don’t misunderstand the responses either.

    So if you had time to respond to this message, I’m still wondering what the answer is and if this is a feature that is actually part of Jigoshop or not…

    ebiker4218

    @ebiker4218

    …he did ask if you could post on their forums, i believe it helps the wider community having all questions in the one place..

    Treebeard

    @malawimama

    Yes, I did, this morning at 3:45am: http://forum.jigoshop.com/discussions/problems/4320-category-image-is-not-showing-on-frontend?unresolve=true

    It doesn’t look like anyone there has had a chance to see my message yet though. The autoresponse he was referring to, was from the post in the forums, I guess it sends out an email when you post a question.

    hey people I found a $5.00 category image plugin here, couldnt see spending 30 for something you would think would be standard. this works well and was easy to afford

    http://www.oscanyon.com/products/jigoshop-category-image-plugin/

    I should have also said I do have it and it works great, very simple to use
    http://www.oscanyon.com/products/jigoshop-category-image-plugin/

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] [Plugin: Jigoshop] Category image is missing’ is closed to new replies.