Support » Plugins » [Plugin: jetpack] site_inaccessible

  • Hi, I’ve two sites: and, both on hosting.
    I installed jetpack on the first one and all is ok, but when I installed on the second one the result is:

    Your website needs to be publicly accessible to use Jetpack: site_inaccessible

    Error Details: The Jetpack server was unable to communicate with your site [HTTP 503]. If you are hosted with Go Daddy, they are aware of this issue, and we at are working with them to fix it. If your site is hosted elsewhere, please contact Jetpack Support:

    I’m reading a lot of topics on the forum with the same problem, but without results.
    I wrote a contact form for the support, but no aswers yet.
    Have you a solution for this problem please, I need the same plugins on two different sites with different languages but with the same contents and this is a problem for me, at this moment, to have jetpack installend on one site only.
    Thank you in advance.

Viewing 15 replies - 1 through 15 (of 19 total)
  • We are encountering the same problem. We have a multi-network WP environment. We installed JetPack on one site when we were running 3.2 ( The installation went fine and it’s still working well.

    We since upgraded to 3.3. After the upgrade, we attempted to activate JetPack on other sites in our installation ( and We are getting the “site_inaccessible” message on these. Oddly enough, the original successful installation is doing fine.

    We are thinking this may have something to do with the upgrade, but can’t find any answers to this in the forums. Thank you for any help you can give.


    Same with my site
    I have also searched a lot but same as stated before i.e. with no results. Please if any one know how to resolve this kindly reply.

    I am getting the same “site_inaccessible” HTTP 503 error – my hosting is on a VPS at Servint which is located in Washington DC. I am running WordPress 3.3.1.

    Any suggestions?


    The issue was to do with running the Elegant Themes Anticipate plugin.

    Anticipate prevents access to xmlrpc.php and hence the callback from was being blocked. (Anticipate is basically using the wrong WordPress hook)

    I was able to work around the issue by deactivating Anticipate, then configuring JetPack, then reactivating Anticipate

    @russell: if Anticipate is blocking access to xmlrpc, be aware that even after Jetpack is connected, there will be times when Jetpack needs access to xmlrpc to do its work (accessing Stats, during upgrades, for email subscriptions, etc.).

    Many Thanks Tim. That’s a good point.

    I will try and tweak Anticipate by adding xmlrpc.php to its list of exception URLs.

    var $_exception_urls = array( 'wp-login.php', 'async-upload.php', '/plugins/', 'wp-admin/', 'upgrade.php', 'trackback/', 'feed/' );

    I got this message:

    “Your website needs to be publicly accessible to use Jetpack: site_inaccessible Error Details: The Jetpack server was unable to communicate with your site [HTTP 500]. Ask your web host if they allow connections from If you need further assistance, contact Jetpack Support:”

    I have tried everything, deactivate all plugins, deinstall the jetpack and reinstalling it, nothing works. Helpp, what should I do?

    I am in the same situation as dedydahlan above. site_inaccessible error. It’s a recent WordPress installation on BlueHost using the current version 3.4.1 and the TwentyEleven theme.

    I have successfully installed Jetpack on a subdomain with the same version of WordPress and almost the same list of plugins:

    April’s Super Functions Pack
    Cashie Commerce (installed but never activated)
    CleanSave (installed after first having the Jetpack problem)
    Last Modified TimeStamp — (installed after first having the Jetpack problem)
    Twenty Eleven Theme Extensions
    Ultimate TinyMCE
    Wiziapp (installed but never activated)
    WP Total Hacks

    ALL were deactivated on the main site. Then Jetpack was deactivated, uninstalled, re-installed, and activated. I still get the same error.

    Update: My problem has been solved.

    A friend of mine discovered it through this thread on

    Sure enough, we did a file search in our file manager, and the xmlrpc.php file was missing from our main domain.

    He copied the file from the installation of WordPress on our subdomain where Jetpack worked fine, and pasted it where it should have been.

    It’s not clear why that file was missing in one installation of WordPress but present in the other since both were installed automatically using the SimpleScripts provided by BlueHost.


    I have the same problem and you are the only person who seems to have a solution (I’ve searched the forums etc). I am a novice website builder and don’t really understand how I would locate the folder to identify whether or not the xmlrpc.php file is missing. Can you point me in the right direction? Many thanks in advance.

    Your website needs to be publicly accessible to use Jetpack: site_inaccessible Error Details: The Jetpack server was unable to communicate with your site [HTTP 408]. Ask your web host if they allow connections from If you need further assistance, contact Jetpack Support:

    Same issue here. Brand new installation, no plug-ins yet at all. I’ve installed half a dozen WordPresses on this server without an error message like this. I do have xmlrpc.php (to the above enquirer, it’s in your main WordPress directory).

    Just an update on my problem – Jet pack suddenly came alive a day or two later. I can only imgaine that it needed all the domain set up stuff to be sorted out behind the scenes. Anyhow, if you have the same problem with a brand new domain or a recently transfered one, I recommend giving it a few days to sort itself out – I have had no further problmes with Jetpack. Hope this helps.

    Thank you, mrfefe. I’ll wait a few more days. WordPress was installed on it on Saturday NZDT so I hope it comes right soon. I’ve never had to wait before so I assume the new WordPresses are less efficient then?

    This might help for some users having the inaccessible site issue:

    Having the “maintenance mode” ON, depending on the plugin you’re using, blocks external access, such as the one required by JetPack to connect through Deactivating the maintenance plugin resolves the issue. Although, even if you deactivate the maintenance plugin you’re using, connect Jetpack through, then reactivate the maintenance plugin, JetPack might still have a problem accessing your site/subsite.

    This might be quite obvious for some, but it may not be so for novice users.

    Perhaps this will solve some of the problems listed here: create an .htaccess file in your root directory and add this to it:

    <Files xmlrpc.php>
    SecFilterInheritance Off

    This assumes, of course, that your xmlrpc.php file is present in the root directory also.

    For me, this was a quick and effective fix for this jetpack error message as well as other confusing connection errors involving remote posting on a self-hosted wp site (e.g., blogpress for iOS). Hope this helps!

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Plugin: jetpack] site_inaccessible’ is closed to new replies.