WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Jetpack] Can't comment on Carousel images – error

[Plugin: Jetpack] Can't comment on Carousel images – error

Viewing 15 replies - 1 through 15 (of 18 total)
  • aboscolo77
    Member

    @aboscolo77

    Same error here….

    Any fix?

    Trainman1405
    Member

    @trainman1405

    I haven’t found anything helpful yet. 🙁

    Jake
    Member

    @noteverjoe

    Same thing happening with my site. Anyone have any luck finding a fix? This seems to be the only place anyone has mentioned it.

    TomerBu
    Member

    @tomerbu

    Experiencing the same error myself – the comment feature is a major Jetpack advantage over other gallery plugins (such as Colorbox, which is more customizable and better looking.)

    Hopefully this will be fixed in newer versions.

    Thanks for the plugin and have a great day. 🙂

    Trainman1405
    Member

    @trainman1405

    Just an update:

    Recently moved from HostGator to a VPS and somehow that made the error go away for me. No idea what actually changed so that it worked, though.

    volition.design
    Member

    @volitiondesign

    First of all, thanks Syed for extracting this cool gallery carousel out of the Jetpack module and uploading it as a separate plugin.

    I am also facing the same problem. Image commenting does not work and gives the error – “Sorry, but there was an error posting your comment. Please try again later.”

    Syed, could you please look into this as many of us are facing the same problem. Thanks!

    volition.design
    Member

    @volitiondesign

    I have fixed this issue on my website. When I looked closely be debugging, I got the error – “call to undefined function switch_to_blog()”

    That function is being called on line 305 in jetpack-carousel.php

    I have only one blog so I don’t need blog switching, and hence commented the entire if block. That fixed the issue for me.

    jdblundell
    Member

    @jdblundell

    I’m having the same issue with WordPress 3.4.2 and Jetpack 1.7 on Hostgator shared hosting.

    New photos 9/23/12

    Voliton.design can you tell us what you did to fix the issue?

    Did you simply delete the line or correct it.

    I’m seriously considering moving my photos from Flickr to my personal sites but I’d like to get this fixed first for sure.

    jdblundell
    Member

    @jdblundell

    I noticed tonight that when I activated the carousel portion of Jetpack on another site hosted on the same domain (with Hostgator) I received the same error.
    I tried deactivating the comment feature of Jetpack and it didn’t fix anything.
    I also tried disabling every other plugin on the sites and that didn’t change anything. 🙁

    volition.design
    Member

    @volitiondesign

    Hi jdblundell,

    Comment the entire if block at line 305 in file jetpack-carousel.php like this, and see if that fixes the error for you.

    // Used in context like NewDash
    $switched = false;
    /* commented because this code is giving fatal error
    if ( $_blog_id != get_current_blog_id() ) {
    switch_to_blog( $_blog_id );
    $switched = true;
    }
    */

    See how I have commented the entire if block in that file. I only have one blog so I don’t need blog switching. $switched is set to false, so this worked for me.

    jdblundell
    Member

    @jdblundell

    @volition

    Thanks! Those were lines 299-304 for me and 305 was blank so I wasn’t sure what you commented out.

    That seems to have worked. I actually have multiple blogs and multiple blogs linked to my WordPress.com account thanks to JetPack so not entirely sure what the feature does – but obviously killing it works.

    Thanks again!

    volition.design
    Member

    @volitiondesign

    @jdblundell

    I am glad it worked for you. Happy to help!

    The blog switching is required for a multisite network of blogs.

    http://codex.wordpress.org/Create_A_Network

    If you have not enabled multisite, I think you don’t need blog switching. So we can safely comment those lines.

    TomerBu
    Member

    @tomerbu

    Thanks, volition.design.
    The solution you offered Works like a charm.
    That’s a major improvement.

    gonna do the happy dance now.
    Cheers and many thanks 🙂

    Volitions fix worked great – but as often as Jetpack gets updated – that’s gonna be a pain to edit every time. Hopefully someone from Automatic is monitoring this thread and fixes it.

    hi there i’ve tried Volition.Design fixing way still no luck same error
    Sorry, but there was an error posting your comment. Please try again later.

    really annoying

    is anyone know another way to fix ?

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Plugin: Jetpack] Can't comment on Carousel images – error’ is closed to new replies.