Support » Plugin: Jetpack by WordPress.com » [Plugin: Jetpack by WordPress.com] You have failed to authenticate with the WordPress.com API

Viewing 15 replies - 16 through 30 (of 49 total)
  • I’ve been seeing this issue intermittently too. I think the problem lies on the wordpress.com side of things. It’s a new plugin that uses some new features. Might take them a while to work out all the kinks.

    BLEH, I reauthorized Jetpack, now getting the same freakin error message. API not vaild. Crap.

    Okay, back to plain old WP-Stats.. Screw Jetpack.

    Now neither works. Anyone know a better plugin, I’m all ears.

    Same issue. Before adding jetpack, WP-Stats was working just fine (chrome 10.0.648.133, firefox 3.6.15, IE 8.0.7601.17514). After adding jetpack, it work for couple of hours. Now it didn’t. I have tried to use some called “solution” : disconnect then reconnect jetpack to wordpress.com, uninstall then re-install jetpack, create another wordpress.com account to have new API key then change the API key. None of them work for me. Still “You have failed to authenticate with the WordPress.com API.”

    Ok… So “luckily” there are some other people with the same issue! 😉

    I have the same problem as everyone and have already tried a couple of tricks above. Some worked for a couple of minutes and some didn’t however the problem still remains! 🙁

    Good news as I got it working!!

    It SEEMS that you need to create a blog at wordpress.com first. Even if you have your own self host WordPress blog.

    Now once you’ve created the blog, go to your Global Dashboard on WordPress.com -> Site Stats.
    You’ll see the stats and you’ll see My Blog (Dashboard) [DROPDOWN] + Switch button.
    Now all you need to do is choose your selfhosted WordPress blog from that dropdown menu and click on the Switch button.
    [EDIT: Make sure that Jetpack is connected to WordPress.com]

    As soon as you’ve done this, you can view the stats again through your OWN dashboard!

    This did the trick for me, so perhaps it might help you as well!

    Did not Work!!
    And now i can’t see simple stats i receive the message : *

    Your WordPress.com account, is not authorized to view the stats of this blog.

    Do you try to view the Site Stats through the link which is place under Jetpack?
    This is strange chilmen as it still works for me…. Even after cleaning my cache etc…

    It work for a while after that i have this message : You have failed to authenticate with the WordPress.com API.
    Aggghhhh!
    The “WordPress.com Stats” plugin gives me this answer “Your WordPress.com account, is not authorized to view the stats of this blog. “
    It’s simple i have no more stats in my blog!!!
    What should i do now?

    I will contact wordpress.com i think it’s an API problem, let you know!!

    Do you have one API or more? And did you make a blog at WordPress.com? Not quite sure if that got anything to do with it, but worked for me! 🙂
    That’s a good idea… Good luck with it and sorry if my trick didn’t worked for you.

    Well it’s back again.
    I don’t know what the support team have done, but they did it.
    Thank you WordPress support team if you read this.
    Thanks BioTeck for your help.

    aarondodson Weirdly seems if I re-do the configuration on another blog, but using the same user name it seems to cure the problem.

    Clicking one of the columns of the past week to see more detailed info seems to trigger the problem – sometimes.

    Clicking the columns of the past week seems to be the main cause.

    However sometimes it causes the problem and sometimes it doesn’t.
    Arghh.

Viewing 15 replies - 16 through 30 (of 49 total)
  • The topic ‘[Plugin: Jetpack by WordPress.com] You have failed to authenticate with the WordPress.com API’ is closed to new replies.