WordPress.org

Support

Support » Plugins and Hacks » Jetpack by WordPress.com » [Resolved] [Plugin: Jetpack by WordPress.com] Subscribe Post/Comment button don't show

[Resolved] [Plugin: Jetpack by WordPress.com] Subscribe Post/Comment button don't show

  • guppydas

    @guppydas

    I just realised that Subscribe feature is also available for Posts and comments. However it does not work properly. What I see is a button and no label/text or form for the same.

    Please view the image or you may visit this blog and click on any post, scroll down and see for yourself.

    I hope my understanding is correct and I am reporting something that is a Jetpack feature NOT working.

    Thank you.

    http://wordpress.org/extend/plugins/jetpack/

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Contributor Tim Moore

    @tmoorewp

    Hi,

    All of the Jetpack code is loading correctly. It looks like something in your theme or possibly a plugin is adding a style="display: none" attribute to HTML labels, which is hiding the text that goes with the subscription checkboxes Jetpack puts on the comment form.

    If you switch temporarily to the Twenty Ten or Eleven theme, do you see the checkboxes and text appear as they are supposed to? If this doesn’t help, it would be worthwhile to list what plugins you are running.

    Thanks,

    Tim

    guppydas

    @guppydas

    Thank you Tim,

    I will give it a go and report back with results. For now, at least I am sure I have got it right. There should be subscribe form at the end of the post. If need be, I will take up the matter with the theme developers too. I use a premium theme and they need to know that this is problem. So long as it not generated due use of some other plugin.

    guppydas

    @guppydas

    Ok I switched to TwentyEleven and everything was working fine. I have narrowed down the issue to the Theme I am using.

    I guess I will have to contact the theme authors for support. However, I would appreciate any help, if I can fix the problem on my own. It would be great learning process for me.

    Thank you.

    guppydas

    @guppydas

    Sorry for posting things so rapidly, I get excited/hyper whenever there is a problem and more than that whenever I find a solution to it.

    Here is what is required, I guess this would work for ANY theme related problem with any other Themes, where the Jetpack Post/Comment subscribe/notify don’t show up properly.

    Just add the following code to the end of style.css of the relevant Theme and I guess it should work.

    .subscribe-label {
    display: inline !important;
    }

    This worked! Thanks so much.

    I’ve been trying to figure this out for two days!!! THANK YOU!

    I have the same exact problem, but adding that code to my custom.css file didn’t help. Any other ideas? I’m not very comfortable with css, could I have done it wrong?

    MyHomeSchoolStyle: Suggestion for you.

    CSS has a tendency of not being reloaded so often. Even when you think you have made changes, it may not actually be loading the new file. Try to clear the browser cache. Shutfdown broswer, restart and reload the page again. If you have added the code correctly, I ought to work. Alternatively there could be something else in your Theme code that could be blocking it.

    Believe me I had struggled a lot on this one. The only practical solution I found was the one that I posted about and it works like a charm.

    Thanks for your help, it’s now working great! Looks so much better.

    MyomeschoolStyle: Glad to help. Or shall I say, share a solution to a problem. We all face or the problem and I feel that it is indeed nice to share what worked. I know the feeling when one is frustrated on a trivial issue of something so basic NOT working. 🙂 Have fun.

    thx for sharing this! in conjunction with WordPress.com Custom CSS plugin, I edited it pretty fast 🙂

    Hi,

    Is there a way to disable the two checkboxes that Jetpack adds? I’ve got a comment subscription system running and the one Jetpack adds is basically redundant.

    Thanks.

    Plugin Contributor Tim Moore

    @tmoorewp

    @rdumitrescu: You can disable the Subscriptions module to hide these buttons. Click on the Jetpack menu, then on Learn More by Subscriptions, them click Deactivate.

    Hi all, first time here. I am having a similar problem in that it has to do with JetPack Comments. Whenever I enable JetPack Comments it works for a while so that my users can create and post comments. But then sometime thereafter the POST COMMENTS button/link stops working. When you press on the link/button to post the comment it just doesn’t work. This occurs to me (admin) and all users. The minute I un connect JetPack and just use the default Theme POST COMMENT button it works again. I really would like to use JetPack and its widgets if at all possible. Any suggestions or fixes for this problem.

    Thanks for your help.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] [Plugin: Jetpack by WordPress.com] Subscribe Post/Comment button don't show’ is closed to new replies.
Skip to toolbar