Support » Plugin: Jetpack by WordPress.com » [Plugin: Jetpack by WordPress.com] site_lang_missing

  • I get this error message when I click the “Connect to WordPress.com” button after installation (and yes I have activated it).

    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: site_lang_missing
    Try connecting again.

    Error Details: The required “site_lang” parameter is missing.

    Is there something else I need to install?
    My WordPress installation is hosted on a Norwegian web host, but I run the English version.

    http://wordpress.org/extend/plugins/jetpack/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Lee

    (@diondeville)

    I had this issue. Solved it by changing the backend language to Spanish , connecting Jetpack to WordPress then reverting back to English.

    My site is a WP MS installation running in English. Always has been in English. I used kau-boys-backend-localisation plugin to change the language.

    Thanks for the suggestion!
    Okay tried that. Didn’t work. I also did a complete reinstall, but this didnt work either.

    Any other suggestion?

    Plugin Contributor Tim Moore

    (@tmoorewp)

    Hi bjornart77,

    Are you by chance using a one click installer from your host? If so, you may want to consider downloading the WordPress package from WordPress.org and manually installing it. Then try installing Jetpack and authorizing it.

    Also, more support tips and a contact link for Jetpack support is available at http://jetpack.me/support/

    Thanks,

    Tim

    Tim, thanks!

    I installed WP manually, (or rather, upgraded to the latest version from an old version).

    Plugin Contributor Tim Moore

    (@tmoorewp)

    Did that get everything working for you?

    No, it didn’t (sorry for my rather ambiguous sentence!).

    I also tried to turn off the Total Cache without any result.

    I seem to run out of options here. Will send a message to Jetpack.

    By the way Tim, I read your blog that you work professionally with WP tracking down bugs. If you’d like, I could give you access to WP-Admin.

    My skype is bjornart77

    Lee

    (@diondeville)

    Hi Bjornat, I posted this in response to your question at my blog, it should help:

    Explicitly set a language for WordPress. Browse the directory that contains all of files used by WordPress. Edit wp-config.php to change the bit that reads

    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress.  A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
     * language support.
     */
    define ('WPLANG', '');

    Change the bottom line to

    define ('WPLANG', 'en');

    or

    define ('WPLANG', 'es');

    or to reflect whatever language files you have installed in “wp-content/languages”. The bit that specifies the language used by WP is ‘en’ (for English) or ‘es’ (Spanish).

    If wp-content/languages doesn’t exit (which it will do because you’ve correctly installed Kau Boy’s Backend Localization), create it. Get your language packs from http://svn.automattic.com/wordpress-i18n.

    Now try to install Jetpack again. It’s safe to revert “define (‘WPLANG’, ‘es’);” back to “define (‘WPLANG’, ”);” once Jetpack is installed. Make sure it correctly reflects the backend language chosen for Kau Boy’s plugin.

    Thanks for the tip! But this didn’t work either.
    Any other ideas?

    Lee

    (@diondeville)

    I suspect you have a plugin installed that’s preventing Jetpack from properly detecting the language used by WP. Try temporarily disabling all plugins then re-enabling Jetpack before authorizing it to connect to wordpress.com. Please let me know the result.

    Okay, I disabled all my plugins and now it worked.

    Thanks and cheers!

    Lee

    (@diondeville)

    Fantastic! ‘Cause you wouldn’t have liked the next option – creating an English language file for it. Glad it worked.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: Jetpack by WordPress.com] site_lang_missing’ is closed to new replies.