Support » Plugin: Jetpack by » [Plugin: Jetpack by] Sharing Options Don't Deactivate After Being Unchecked

  • I activated the sharing options for Jetpack. After a few weeks of success I decided to add them to our front page and see how that looked.

    It didn’t look very good at all so I removed the check-mark from Front Page, Archive Pages, and Search Results. I then deleted the cache and refreshed the front page. I was surprised to see the front page still showed the sharing options.

    I checked the options for sharing in Jetpack and verified that Front Page, Archive Pages, and Search Results is still unchecked. It is…

    I’m at a loss of what to do here. The site owner is getting a bit testy. Is there an option in MYSQL I need to change? Any idea why this wouldn’t reset and still show?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor Tim Moore



    Thanks for reporting this bug and I’m sorry for the inconvenience. We’ve corrected the error and a patch will be released in the next version of Jetpack.



    Do you want to tell me what the fix is? I can’t allow my site to look like this until you guys release a new version.

    Please post changed files or whatever code edits need to be made

    Plugin Contributor Tim Moore


    @mykkal: The next bug fix release is coming very soon (this week), which will include this fix.

    Until then, here’s an updated file that should help. Unzip this and drop it in your Plugins -> Jetpack -> Modules -> Sharedaddy folder. Then go back to your Dashboard -> Settings -> Sharing panel in your browser, check your settings, and clear your cache again. Everything should be back to the way you want it.

    Let me know if that helps.



    Thanks I will try this right away!

    its been two months since they said i’d get a quick fix in a few days.

    my site is still screwed up with this bug. damnit! be responsible!

    where is the fix? jetpack has my site looking highly unprofessional! automatic is highly unprofessional.

    new versions of jetpack have been released buy they keep ignoring this bug!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    [Please stop posting in uppercase. It’s the electronic equivalent of shouting and is considered quite rude. Post de-capped.]

    Plugin Contributor Tim Moore



    I posted a quick fix for you above that should’ve got you going before a new version of Jetpack came out. The newest version of Jetpack that is out also contains this fix. At that time, I verified that this fix worked on one of my blogs, which was showing the same error you described.

    Could you try the following steps, please?

    – Disable all plugins, except Jetpack
    – Temporarily change themes to Twenty Ten or Twenty Eleven
    – Clear your browser cache
    – Recheck your blog for the proper settings
    – If everything works as intended, turn your theme back on and check for proper settings again.

    If the error still shows up after you go through the above steps, please post the following information:

    – WordPress version
    – Jetpack version
    – Any caching plugins in use
    – OS / browser in use

    At this time, I can no longer reproduce the error on my test blog, so any info you can provide would help me assist you in resolving this.



    1. In the newest version of jetpack… It is not fixed.

    2. We’ve disabled jetpack for now becuase when enabled the website does not display correctly in I.E. 9 (with or without compatibility mode active). Disabling jetpack allowed our site to display as designed. There are no conflicts as this still happens when jetpack is the only plugin in use.

    3. The download you said you posted well…if you click the link there is nothing there and hasn’t been since I first tried.

    I would really appreciate a fix and it would be nice if Automatic actually did a more thorough quality assurance on the plugin.

    Please let me know when a fix is available. Right now we have no sharing avail which is a big part of our traffic. WordPress is made by Automatic and so is Jetpack.

    I’m using W3 total cache and the version of the wordpress is 3.3.1.

    This is really horrendous.

    Plugin Contributor Tim Moore


    Will the website display correctly if you switch to one of the default themes? I am still unable to reproduce the same issue, even in IE 9, so I’m curious if it might be related to a custom theme.

    There is also a known conflict between W3 Total Cache and Jetpack, so it might be worthwhile to clear W3 Total Cache, disable it, then set up Jetpack as you desire before re-enabling W3 Total Cache.

    if you click the link there is nothing there and hasn’t been since I first tried.

    I apologize if the download link never worked. It had worked for me and I did disable it after we launched a new version of Jetpack that had this patch in it.

    WordPress is made by Automatic and so is Jetpack.

    Actually, no. and Jetpack are Automattic products. WordPress the software, which you download from, is an open source product, separate from Automattic. You can read more about that here, if you’d like.

    I’m using theme hybrid Version 1 right now with hybrid news .3 as the child theme. I tried clearing, disabling, deactivating the W3 cache but as soon I turned on jetpack the issue return. In fact it stayed even as caching plugin was fully deactivated.

    Is there a database setting that should be adjusted so that it doesn’t display on the front page?

    I am having the issue as well. Anyone get this resolved?

    Plugin Contributor Tim Moore


    We’re working on the bug. No ETA on a fix yet; keep an eye on our news site for an update.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: Jetpack by] Sharing Options Don't Deactivate After Being Unchecked’ is closed to new replies.