Support » Plugins and Hacks » Jetpack by WordPress.com » [Plugin: Jetpack by WordPress.com] Sharing buttons not showing on the front page

  • Resolved ecabral

    (@ecabral)


    The sharing buttons won’t show on the front page even though the ‘Front Page, Archive Pages, and Search Results ‘ option is checked in the Sharing Settings. I activated a different theme (Twenty Eleven) just to check if it would be an issue with my theme, but it also didn’t show. The buttons show in the other locations that I’ve specified.

    Additionally, I’m using all sharing buttons hidden behind a Share button. This is a really nice way of keeping my pages uncluttered while benefiting from the functionality of the social buttons. However, when I try to share a page using the G+ button I’m not able to choose who to share it with. The sharing pop-up disappears straight away.

    http://wordpress.org/extend/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 15 total)
  • I have the same problem. My blog is self-hosted at http://nakednutritarian.com. Even though I have the ‘Front Page, Archive Pages, and Search Results’ option checked, the sharing buttons do not appear on my blog’s front page. As with the OP, the buttons do show on my other pages.

    Plugin Contributor Tim Moore

    (@tmoorewp)


    Do either of you have a caching plugin installed?

    We are aware of the G+ sharing issue and are working on it.

    I don’t have a caching plugin that I know.

    I assume the buttons won’t show on my front page, http://www.antoniocabral.com.pt/, because Jetpack doesn’t know where to place them… No idea how to solve this.

    Thanks!

    Plugin Contributor Tim Moore

    (@tmoorewp)


    Sharing relies on the hooks “the_excerpt” and “the_content.” If your theme doesn’t use these on your front page, that is why you aren’t seeing anything show up.

    Yeah, makes sense. Thanks!

    Tim, thanks for the quick reply. No, there is no caching plugin on mine either.

    Like ecabral, my theme doesn’t appear to have either of those hooks on the front page either, so that’s probably the cause of the problem.

    Is there a way to manually insert the Sharing buttons, either in a text or PHP widget or by editing the template? Apparently Sharedaddy allowed you to enter:

    <?php echo sharing_display(); ?>

    Will that work with the Jetpack implementation also? And is there anything else I would need to do?

    Plugin Contributor Tim Moore

    (@tmoorewp)


    <?php echo sharing_display(); ?> should still work in Jetpack.

    I’ve been having the opposite problem on two sites, both with different themes (one of which is Oxygen). I don’t want the sharing buttons to appear on the front page, just the posts. I have deselected all options but posts on the Share settings but it still appears on the front page.

    Any suggestions?

    Same problem as @actionmatt. Is there a workaround?

    erlo

    (@erlo)


    Hello,
    Question, how can I remove ALL the settings from wp socializer? I run into problems with certain settings and cant put it the right way. So I wanna romove WP socialzer completely and try all over. Now it seems as if that isnt possible. Removed it and when I run it again it uses all the old settings. HELP
    Erlo

    Same problem as @ecabral and <?php echo sharing_display(); ?> isn’t showing anything??

    Any suggestions?

    Cheers,

    Belinda

    thanks @wekking & @sonnythao I tried your solution and it worked…

    1. Logged into my self hosted WordPress blog.
    2. Clicked on Posts.
    3. Clicked on an existing post.
    4. Clicked the Screen Options button in the upper-right corner > Checked the Excerpt box. (You only do this once and then all other posts should have the Excerpt field show up.)
    5. Went to the Excerpt field and just enter a space.
    6. Clicked Settings > Sharing.
    7. Dragged in the social media services into the Live Preview area > Save Changes.
    8. Voila! Your post has the social media buttons!

    My sharing buttons show on my posts and pages, but not on my portfolio pages..even though Ive selected the correct settings. Any one have an idea what’s going on? Im using Yin and Yang theme by OnionEye. Thanks in advance!

    These buttons are not showing for me at all, on any page regardless of post type. I am using the 2012 Theme, my URL is http://savagemike.me.

    Not sure what’s up, I’ve tried some of the above, but nothing helps. In particular the steps outlined above by Belinda make no sense.

    Any advice is appreciated.

    Hello @mikelawrey32 and @savagemike because this support ticket has been resolved, it would be much better for you to start a new support ticket. This would increase your chances of receiving quick support.

    Kind regards

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: Jetpack by WordPress.com] Sharing buttons not showing on the front page’ is closed to new replies.