Support » Plugin: Jetpack by » [Plugin: Jetpack by] register_http_request_failed

Viewing 7 replies - 1 through 7 (of 7 total)
  • shahilj


    Seems like this is a common problem. The error I’m getting is:

    Jetpack could not contact register_http_request_failed. This usually means something is incorrectly configured on your web host. 13: Permission denied


    I sometimes get that when having hosts either behind a firewall, or with a cache plugin (I usually use W3 Total Cache) turned on.

    In the latter case, the trick is often to temporarily disable the cache, allow JetPack to connect, and enable it again. This often works.

    Sometimes it’s just the JetPack webservers that are over demand. Connecting at a different time usually fixes that.

    But more recently I have noticed that the fallback from HTTPS to HTTP (when connecting behind proxies/firewalls) tend to give either that error, or the even more strange “0” error. Logs show that the HTTPS connection failed, but JetPack doesn’t seem to fallback to connecting to HTTP any more.

    Plugin Author Beau Lebens



    Thanks Gwyneth.

    Indeed, W3 Total Cache is probably the most common cause for this error that we see. Are you (krivik/shahilj) using that plugin? Can you try temporarily disabling it and connecting Jetpack?

    Hey. Thanks for the reply! I’ve looked through everything with my (limited) knowledge and have a feeling its an issue on the hosts side. I’m not using the W3 plugin that you are talking about nor am I using any other plugin which would do anything similar to what you have mentioned.

    I’m going to try two approaches: Diasble ALL plugins temporarily and try connecting again or if that fails, call my host 😉 Will report back!

    Some hosts do, indeed, block outgoing HTTP/HTTPS requests. Nevertheless, if your blog auto-updates regularly from WordPress (i.e. if you get notifications for new plugins or themes, or new versions of WP), then it means that at least outgoing HTTP calls must be working fine on your host’s configuration.

    If they have to enable outgoing requests one by one, remember that JetPack uses both and Both resolve to a wide range of IP addresses, and it’s best if your host can enable outgoing calls to the domain names (which can change over time…).

    Plugin Contributor Tim Moore


    With no updates in a week, I’m marking this as resolved. Please reopen as needed or post a new topic for us to work in. Thanks!

    Thanks for the replies! I tried everything and it still refused to work. Then I upgrade to 3.4.2 and it magically worked. I didn’t question this and I am now a happy Jetpack user! Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Jetpack by] register_http_request_failed’ is closed to new replies.