Jetpack by WordPress.com
[resolved] Messed up Sharing screen in Jetpack 1.2.2 and WP 3.3 (22 posts)

  1. music2myear
    Posted 4 years ago #

    Sharing Settings screen in Jetpack 1.2.2 and WP 3.3 is unusable due to misplaced elements.

    The most obvious visible issues are the large "Drag and drop available services here" and "Sharing is off. Please add services above to enable" appear behind most of the other control elements and are unusable, preventing me from enabling Sharing.

    Issue occurs in FF and IE (both latest non-beta) regardless of window size, maximize status, etc).


  2. Beau Lebens
    Plugin Author

    Posted 4 years ago #

    Hi music2myear, can you provide a screenshot and perhaps the results of a "View > Source" for that page from your site please?

    I'm looking at this on a test site (scrolled down so you can see I'm using 3.3)


    Also -- is your install using a non-standard wp-content directory or something like that perhaps? It sounds like some CSS is not loading or something.

  3. music2myear
    Posted 4 years ago #

    Here's a screenshot of what I see when I try to manage sharing in Jetpack.

    There is no custom CSS or site configuration involved here that I'm aware of. It's a standard install I've been running since I think 1.7 version of WP.

    I disabled all plugins except JetPack to verify no issues there and the issue was the same.

    I have deleted Jetpack and reinstalled the plugin: same issue.

    The issue occurs on all computers I have access to as well as an iPad.

  4. Beau Lebens
    Plugin Author

    Posted 4 years ago #

    Wow that is super ugly :)

    Are you able to view the source of that page and send a copy of that by any chance?

    Also, if you look at it in Chrome or use FireBug for Firefox, can you see if loading that page is triggering any 404 errors perhaps? It definitely looks like your CSS isn't completely loading.

  5. Samuel Aguilera
    Posted 4 years ago #


    I have similar problem.

    In my case I can see the share settings page wihout visual problems, so it looks ok. But I can't drag and drop the sharing services.

    If I try to drag one, text of the page is selected instead...

    Here you can see the page code (for /wp-admin/options-general.php?page=sharing): http://pastebin.com/RR9sUJX4

    Same WP and Jetpack version. Tested with Firefox 9.0.1, Explorer 9.x and Chrome 16.x, with the same result in all browsers.

  6. music2myear
    Posted 4 years ago #

    Here's the code from the Sharing page of the Jetpack plugin:

    [Code moderated as per the Forum Rules. Please use the pastebin]

  7. music2myear
    Posted 4 years ago #

    I'll check with Firebug shortly.

  8. music2myear
    Posted 4 years ago #

    Here's a re-paste of the code: http://pastebin.com/4CpwnPdc

    Also, checking firebug, there are 403 Access Forbidden errors on the following files:

    • .\wp-content/plugins/jetpack/modules/sharedaddy/admin-sharing.css?ver=0.3
    • .\wp-content/plugins/jetpack/modules/sharedaddy/admin-sharing.js?ver=1

    Permissions on each of these files are 0644.

  9. Beau Lebens
    Plugin Author

    Posted 4 years ago #

    @Samuel: can you access the files in @music2myear's post (on your site)?

    I'm not sure why these files are restricted from your web server, but that appears to be what's causing the problem.

    Can you try downloading a clean copy of Jetpack and copy over those files perhaps? 0644 should be fine to at least allow your webserver to read them, unless you have some additional security in place perhaps which is blocking access to files with "admin" in the name or something like that?

    My permissions look like this:

    [minelava]$ pwd
    [minelava]$ ls -alFh
    total 236K
    drwxr-xr-x 3 beaul pg114338 4.0K 2011-12-05 16:10 ./
    drwxr-xr-x 6 beaul pg114338 4.0K 2011-12-05 16:10 ../
    -rw-r--r-- 1 beaul pg114338 7.6K 2011-12-05 16:10 admin-sharing.css
    -rw-r--r-- 1 beaul pg114338  12K 2011-12-05 16:10 admin-sharing.js
    drwxr-xr-x 2 beaul pg114338 4.0K 2011-12-05 16:10 images/
    -rw-r--r-- 1 beaul pg114338 3.8K 2011-12-05 16:10 readme.txt
    -rw-r--r-- 1 beaul pg114338  58K 2011-12-05 16:10 screenshot-1.jpg
    -rw-r--r-- 1 beaul pg114338  27K 2011-12-05 16:10 screenshot-2.jpg
    -rw-r--r-- 1 beaul pg114338 4.5K 2011-12-05 16:10 sharedaddy.php
    -rw-r--r-- 1 beaul pg114338 7.1K 2011-12-05 16:10 sharedaddy.pot
    -rw-r--r-- 1 beaul pg114338  16K 2011-12-05 16:10 sharing-service.php
    -rw-r--r-- 1 beaul pg114338  33K 2011-12-05 16:10 sharing-sources.php
    -rw-r--r-- 1 beaul pg114338 6.3K 2011-12-05 16:10 sharing.css
    -rw-r--r-- 1 beaul pg114338 8.7K 2011-12-05 16:10 sharing.js
    -rw-r--r-- 1 beaul pg114338  17K 2011-12-05 16:10 sharing.php
  10. music2myear
    Posted 4 years ago #

    Found the problem.

    .htaccess file in /wp-content/plugins had the following:

    <Files ~ ".*\..*">
    order allow,deny
    deny from all

    .htaccess file probably originated from a security plugin suggested configuration. Removing the .htaccess file and the errors went away and the plugin pages load just fine. Looks ok now.

  11. Beau Lebens
    Plugin Author

    Posted 4 years ago #

    Weird, that's definitely not a normal configuration. You could probably adjust it to allow access to .js, .css and .(gif|jpg|png) files to keep the extra security but allow other plugins to work normally, but removing it sounds like it's got you fixed regardless.

  12. Samuel Aguilera
    Posted 4 years ago #

    @Beau I don't have that file permissions problem on my site. And no .htacces file in the /wp-content/plugins dir...

    But the problem persists. I can't drag and drop the sharing services buttons to activate them :(

  13. Beau Lebens
    Plugin Author

    Posted 4 years ago #

    Samuel does your Sharing screen look exactly like this one?


    Can you access your admin-sharing.css and admin-sharing.js files directly?

  14. nsuhick
    Posted 4 years ago #

    I have the exact same problem. My screen looks exactly the same as music2myear's but I don't have the .htaccess file.

  15. mozzer502
    Posted 4 years ago #

    Does anyone have a resolution to this? I'm seeing the same issue. My file permissions look right.

    I've deleted the plugin and re-added it and no difference.


  16. mozzer502
    Posted 4 years ago #

    additionally, I've noticed that the main visual toolbar from the Add Post page is missing. The HTML toolbar is fine.

    I've deactivated the plugin and the toolbar returns.

    Clearly something is wrong with my JetPack installation.

    The only other plugins I have installed are google analytics and AddThis. I recognize that addthis will not be needed once I get JetPack to work so for now it's deactivated

  17. Shanta R. Nathwani (TantienHime)
    Posted 4 years ago #

    Believe it or not, I think I've figured it out!

    I read through this post and compared my self-hosted to my .com version. In my self-hosted (which wasn't working) I changed "Open Links In:" to New Window from Same Window. After that, I was able to drag and drop the icons and activate the plugin. Weird I know, but will keep you posted.

  18. Akshay2598
    Posted 4 years ago #

    I have the same problem, the CSS and JS is messed up. Someone please help. I tried the Open Links in New Window and Tab but it doesn't work :(

  19. mozzer502
    Posted 4 years ago #

    I couldn't fix my problem. None of the the solutions presented here helped.
    However, I realized that my host was just terrible at wordpress, so I moved to a new vendor and now everything works

  20. Akshay2598
    Posted 4 years ago #

    Solution thanks to Mike from WordPress:

    Are you comfortable editing PHP files? If so, are you able to edit PHP files on your host?

    If so, edit wp-content/plugins/jetpack/modules/sharedaddy/sharing.php. Find "public function subscription_menu".
    It should be around line 45: http://plugins.trac.wordpress.org/browser/jetpack/tags/1.2.4/modules/sharedaddy/sharing.php#L48

    Make it look like:

    public function subscription_menu( $user ) {
    $hook = add_submenu_page( 'options-general.php', __( 'Sharing Settings', 'jetpack' ), __( 'Sharing', 'jetpack' ), 'manage_options', 'sharing', array( &$this, 'management_page' ) );

    var_dump( $hook );

    // Insert our CSS and JS
    add_action( "load-$hook", array( &$this, 'sharing_head' ) );

    You can copy and paste from this pastebin, if it's easier: http://pastebin.com/8B3Ywkqk

    Save the file then go to your Sharing settings. You should see an ugly message at the top of the screen in quotes. Could you paste that ugly message in a reply here?

    If the rest of the page looks pretty, that edit has fixed the problem, and we'll include the fix in the next release of Jetpack. You can remove the "var_dump" line from the file I asked you to edit, and you'll be all set.

    If the rest of the page still looks ugly, we'll have to debug some more. Let us know.

    Either way, please delete that "var_dump" line. The rest of your admin will probably break if you leave it in.

    If you're not comfortable editing PHP files, or you can't edit files on your host, let us know and we can find another way to test the problem.

  21. sonyericssonxperia
    Posted 4 years ago #

    I made some CSS tweaks to get the alignment correct. Still, you could observe the issues at the following pages:
    (Displayed incorrectly)
    I added a couple of CSS modifiers to get the alignment correct, but the FB button still gets messed up. This happens only on product pages, the alignment on news pages is perfect.
    Another issue noticed is when the sharing buttons are not under a commone "Share" button. The vertical alignment is messed up, and they dont come under a centrally aligned axis.


  22. Johanhorak
    Posted 4 years ago #

    I have the same problem. I tried the idea above. But it did not work. I re-installed Jetpack. ;-(

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic