WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Jetpack by WordPress.com] Jetpack's twitter widget does not save my username

[Resolved] [Plugin: Jetpack by WordPress.com] Jetpack's twitter widget does not save my username

  • I am trying to configure the Jetpack’s twitter widget on my self-hosted blog.
    I’m adding the widget to the sidebar and changing the configuration. For username, I have entered ‘jcberthon‘ but when I hit Save, the username is empty again.
    I have tried with other username, thinking it might be my account. But I have the same behaviour.
    Does this widget work with a self-hosted WordPress? How can I debug it?

    Note: I have WP 3.4.2 and Jetpack 1.8.2 and using Twenty-Twelve theme. The widget never worked on my website, however with previous versions of WP/Jetpack, the username was not reset when saving. So I had no clue what was going on.

    The blog I need help with is http://www.berthon.eu.

    http://wordpress.org/extend/plugins/jetpack/

Viewing 15 replies - 16 through 30 (of 31 total)
  • It would be great if we could get an official fix…

    Plugin Contributor Hew

    @hew

    Hi all,

    Thanks for the feedback. We’re looking into this.

    Sooner the better for a fix but I wonder whether the problem isn’t Twitter itself? I tried to bale out on the Jetpack Twitter widget and tried Twitter Widget Pro (free) and it wouldn’t work either!

    Plugin Contributor Tim Moore

    @tmoorewp

    This issue is related to some access issues with Twitter’s API. There isn’t a lot we can do, though the issue seems to be resolved now. My apologies for the inconvenience.

    When I go on widget page and I try to add my username, plugin doesn’t save it so for me the issue is not resolved for now 🙁

    Does it work now for you ?

    Please stop posting the same information multiple times.

    Sorry, i have refresh my browser and I cant’t delete my multiple message 🙁

    Plugin Contributor Tim Moore

    @tmoorewp

    @siriu: it is working for me. It is possible that your server can not communicate with Twitter and is having an issue. I have made some updates to our code that will come out in Jetpack 1.9 (no release date yet) that may fix this for you.

    Thank you Tim. Once it is release I will try again the code.
    Do you have an idea how to investigate communications problem between my server and Twitter?
    Note: I’m on a shared-hosted server, I don’t have SSH access, but I can consult the apache logs and any logs produced by WordPress

    Plugin Contributor Tim Moore

    @tmoorewp

    If you upgrade to Jetpack 1.8.3, you shouldn’t need to worry about this anymore. We’ve updated our code to, hopefully, resolve this issue.

    Please Help:
    Here are the steps I have taken, amongst reading the forums, and all I can do which includes:trying other widgets, going to twitter.com and trying official twitter widget, looking for updates, making sure my everything is updated and using current updated versions of WP, and the plugins. I do not know what else to do. So
    1. I activated jetpack plugin
    2. I created a WP.org and WP.com account.
    3. I am hosting with GoDaddy
    4. My website is http://www.1800Collete.com
    5. My twitter is http://www.twitter.com/1800Collete
    6. I went into my widgets after activating Jetpack
    7. I placed the FB plugin on sidebar top (It opened up, worked fine!)
    8. I placed the Twitter plugin on sidebar top underneath the FB plugin and here is the message I received:
    Twitter Updates
    <p>Error: Twitter did not respond. Please wait a few minutes and refresh this page.</p>
    9.Deactivated Jetpack,and tried official twitter widget from twitter site, nothing!
    10. Tried other twitter plugins and coming up with errors.

    Please Help!
    Signed, Need WP Love

    hi Tim, I’ve just installed Jetpack 1.9.2 in the hope of finding a Twitter feed widget that works, but am sadly getting the error <p>Error: Twitter did not respond. Please wait a few minutes and refresh this page.</p>.

    As huygens-25 suggested, is it worth investigating the state of comms between host and Twitter ? With almost every widget I’ve tried there seems to be a glitch.

    Thanks for your help. John

    Plugin Contributor Tim Moore

    @tmoorewp

    Twitter has been changing its API and locking it down. It is quite likely that if you are on shared hosting, your host’s server has been blocked by Twitter because, between all of the sites on the server, Twitter has seen too much traffic from that one server.

    This isn’t something that Jetpack or any WordPress plugin can control or prevent, unfortunately.

    Thanks for getting back so quickly. You’ve confirmed what I suspected about traffic sizes. 🙁
    In case it’s of any use, I’ve just installed Tweetview-Widget, which appears to be working and whose changelog says it incorporated the Twitter API change a fortnight or so ago (http://wordpress.org/extend/plugins/tweetview-widget/changelog/). Thanks again, John

Viewing 15 replies - 16 through 30 (of 31 total)
  • The topic ‘[Resolved] [Plugin: Jetpack by WordPress.com] Jetpack's twitter widget does not save my username’ is closed to new replies.