WordPress.org

Support

Support » Plugins and Hacks » Jetpack by WordPress.com » [Resolved] [Plugin: Jetpack by WordPress.com] Jetpack's twitter widget does not save my username

[Resolved] [Plugin: Jetpack by WordPress.com] Jetpack's twitter widget does not save my username

  • I am trying to configure the Jetpack’s twitter widget on my self-hosted blog.
    I’m adding the widget to the sidebar and changing the configuration. For username, I have entered ‘jcberthon‘ but when I hit Save, the username is empty again.
    I have tried with other username, thinking it might be my account. But I have the same behaviour.
    Does this widget work with a self-hosted WordPress? How can I debug it?

    Note: I have WP 3.4.2 and Jetpack 1.8.2 and using Twenty-Twelve theme. The widget never worked on my website, however with previous versions of WP/Jetpack, the username was not reset when saving. So I had no clue what was going on.

    The blog I need help with is http://www.berthon.eu.

    http://wordpress.org/extend/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 31 total)
  • Having the same issue here. Twitter account name is MerrittBMX, for some reason it would never save the full name.

    I tried entering just Merritt (leaving off the BMX part of the username) and it saved it. Went back and added the remaining letters and was able to save.

    Not sure if this will work for you but it helped me.

    Weird issue…

    I have try on different website with the last version of jetpack and same issue… This bug come with the last version of jetpack

    I’m having this same problem.

    It won’t work with any trick to save my username. Anyone?

    Ideas?

    Or can we get a fix?

    Thanks for trying man, but I edited that php file, adding my username in, and it didn’t work.

    So it would be awesome if we could get an official developer to fix this….

    Where did you add the code? If you replaced the initial $via, try adding your line under it and seeing if it works.

    Using that code, it works on my website.

    I’ll copy and paste it here. Pretend my twitter account name is “evilhaxor” (without the quotes). Is this correct? Or where should it go?

    public function get_display( $post ) {
    $via = $this->sharing_twitter_via( $post );
    $via = “evilhaxor”;
    if ( $via ) {
    $via = ‘&via=’ . rawurlencode( $via );

    $related = $this->get_related_accounts( $post );
    if ( ! empty( $related ) && $related !== $via )
    $via .= ‘&related=’ . rawurlencode( $related );
    } else {
    $via = “”;
    }

    Yes, that’s how I have it written and it works perfectly, until they update the plugin.

    shoot. Well this doesn’t work for me

    Hope for an official fix soon…

    Is there some place to submit bugs?

    And I realize, that I am talking about the sharing plugin, this post was regarding the twitter widget.

    I built my own widget in my latest theme, so I don’t have a fix for the “official” widget.

    I really want to apologize for the confusion.

    Weird thing, is by following the trick by MKachtan I manage to save my twitter username. However, that’s several days I see this when seeing my site:
    <p>Error: Twitter did not respond. Please wait a few minutes and refresh this page.</p>

    I did not see once my tweets, and they are all public, so that is not the problem.

    For anyone dealing with the issue of WordPress not saving their Twitter username in the Jetpack Twitter widget:

    After spending hours combing the internet for solutions, I found this:
    http://sherman-media.com/wordpress-text-widget-wont-save-fixed

    On the widgets page, go to Screen Options in the upper right hand corner, and click “Enable accessibility mode”. Then fill out the info as you would normally, and it should save it!!

    Sorry, but this still doesn’t work

    I have the same error as well.

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘[Resolved] [Plugin: Jetpack by WordPress.com] Jetpack's twitter widget does not save my username’ is closed to new replies.
Skip to toolbar