WordPress.org

Support

Support » Plugins and Hacks » Jetpack by WordPress.com » [Resolved] [Plugin: Jetpack by WordPress.com] Jetpack shortlink not working

[Resolved] [Plugin: Jetpack by WordPress.com] Jetpack shortlink not working

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Contributor Tim Moore

    @tmoorewp

    Could you share one of the shortlinks that isn’t working? If you want to keep it private, please send us a ticket.

    Hi, this is one of the links http://wp.me/pFRTI-u2

    Plugin Contributor Tim Moore

    @tmoorewp

    I should’ve included this in my above question, sorry: what is the full URL that the shortlink should go to?

    Plugin Contributor Tim Moore

    @tmoorewp

    Edit that post and click the Get Shortlink button and try the new shortlink it gives you, please. Does that one work?

    I tried that but it gives me the same shortlink.

    Any updates on this?

    Plugin Contributor Tim Moore

    @tmoorewp

    Sorry for the delay. I’m looking into the issue.

    Could you confirm that when you create and publish a new post and then use the Get Shortlink button, that this error is still happening?

    Thanks!

    Yes, it is still happening even for new posts.

    Plugin Contributor Tim Moore

    @tmoorewp

    Sorry about the issues. I’ve updated a few things on my end that should take care of this and allow your shortlinks to work again.

    Hi, thanks a lot. The links are working now. I really appreciate it, Tim.

    hey. i am facing a problem on jetpack link short service, whenever i try to get a short link of any of my post it gaves me short link but that short link always gave me error
    Original Link
    http://empiresandallies.movies-mania.com/2013/01/empires-and-allies-the-warzone-hack/

    short link
    http://wp.me/p2o9CA-12u

    Sorry, we could not resolve that url.

    can you guide me how to fix it ? on my other subdomain on same server its working fine but not working on my other domain

    I just had this happen to me as well. This is what happened.

    1) I set up a new wordpress site at a temporary domain.
    2) From the temporary domain, I connected Jetpack to my WordPress account
    3) I published my site to the real production domain and changed the domain name in the settings of WordPress
    4) Whenever Jetpack would generate a short link, it would point to the old temporary domain instead of the correct production domain.

    Luckily I caught this and then created a 301 redirect at the temporary domain for anyone that saw the short link.

    However, here’s the fix:

    Simply go into your Jetpack plugin settings, then “Disconnect” from WordPress.com. Then re-connect it again immediately. I think this forces Jetpack to read the proper domain settings again, and will start generating proper Short links to your blog.

    Hope this helps.

    Plugin Author Jeremy Herve

    @jeherve

    @clinch Could you please start a new thread about your issue, and let us know your site URL so we can investigate further?

    If you don’t want to share your site URL on a public forum, you can also contact us via this contact form:
    Contact

    No need. The problem has already been solved, as I stated above. I was posting this message for other users that were perhaps having the same problem as me. My steps to recreate and solve the issue are all listed above.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] [Plugin: Jetpack by WordPress.com] Jetpack shortlink not working’ is closed to new replies.
Skip to toolbar