Support » Plugin: Jetpack by » [Plugin: Jetpack by] Jetpack 1.4.2 – Jetpack Comments not working

  • Resolved JordanAlaz


    Hey everyone. This is my first time using WordPress and Jetpack so bear with me a bit.

    I installed Jetpack with the intent of basing my comment system off their new social integration plugin. After installation I’m not seeing any options regarding social integration anywhere on my dashboard, nor am I seeing any changes when I activate Jetpack comments on my page. It just stays the same as it was pre-Jetpack.

    I’m assuming it’s some kind of theme conflict. I would like to know if there’s a way to disable the native theme comments and allow Jetpack comments to be used primarily.

    Here is a link to a test post on the site (with Jetpack comments enabled so you can see there is no change)

    Thank you in advance for the help, I really need it.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Musadiq


    I’m also having the same issue with the jetpack social media comment.

    The comment style below the post did not change and there is no social media icons for people to comment either.

    Thank you.

    I am having the same exact problem with several different themes. In fact I have yet to find a theme where the comments function works. Has anyone got it to work?

    Has this thread been buried? I really need help!

    Same problem..anybody have a solution for this issue?



    Correct me if I’m wrong but I guess this issue is not considered urgent anymore since wordpress 3.4 already got a built in social connect. That is what I’ve read it somewhere in if remember it correctly.

    Anyway, since I’m currently using 3.3.1 and not ready for another round of themes upgrade yet, so my ideal solution for now is using the Social Login plugin. I’ve already installed it today and it works.

    I still have to make a change here and there, but is enough for me and hope if you guys maybe in need of urgent solutions, then maybe you can give it a try. Here is my result.

    Thanks and hope it’ll help.

    Thanks for the tip M3, I’m going to test the Social Login plugin now and update the thread if it works.

    Plugin Contributor Tim Moore


    Your theme needs to use the comment_form() function in order to display Jetpack Comments. Themes that have hard-coded or customized comment forms will not currently work with Jetpack Comments.



    Your welcome Jordan and thanks for the tip Tim.

    @tim, my theme has the following code already. What am I missing?

    <?php do_action('comment_form', $post->ID); ?>


    I tried replacing this with

    <?php comment_form($post->ID); ?> and
    <?php commment_form(); ?>

    But neither of them made any difference.


    Like everyone else, the comments stopped working with this last upgrade. Or should we can it a downgrade? Something as old as writing posts should work. I dumped Jetpack. I rely too heavily on my comments to fool around with this.

    it is also not working for me in Jetform 1.5 either…

    I do have “<?php do_action(‘comment_form’, $post->ID); ?>” inside my COMMENTS.php..

    Any advice ?

    Never mind: Found this and it worked 🙂

    Jetpack 1.4 Comments: how to fix it

    I use Jetpack with the Big City theme and everything was working fine before. All of a sudden, readers can no longer fill in the name/email/website fields above the comments box. I went to Jetpack settings and for some reason it won’t let me activate the comments feature offered by Jetpack, even though I have had comments already on the site (maybe through my theme). Can anyone tell me what’s wrong and how to correct this?

    I’m having this problem too. Comments are not working, and I do have <?php comment_form(); ?> on my comments.php too.

    All I get is a 404 error when I try to elave a comment, either logged in or logged out.

    Anyone found a fix?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: Jetpack by] Jetpack 1.4.2 – Jetpack Comments not working’ is closed to new replies.