Support » Plugin: Jetpack by » [Plugin: Jetpack by] Jetpack 1.2, 11 badge does not go away

  • I am testing out Jetpack 1.2 on a test server before deploying to my multisite network. When I enable Jetpack 1.2 for the first time on a new site, I see an “11” notification badge because there are 11 modules that are new to that site. Okay, great, but I cannot make that badge disappear.

    On sub sites that had the 1.1.3 version of Jetpack previously connected to, I see a “3” because there are 3 new features, but that badge goes away as soon as I click on Jetpack in the admin menu.

    I tried the test on another two brand new test sites, the 11 appears after connecting to for the first time, but does not go away. Also, I cannot configure “Sharing” on sites where Jetpack is newly enabled. Sharing works just fine on sites where 1.1.3 was enabled first. I even tried deactivating and then activating the Sharing feature.

    I tried disconnecting the site from and reconnecting. At the Network Admin level, I also tried the Updates –> Update Network command. I even tried Network Deactivating the Jetpack plugin then re-enabling it, this did not fix the subsites that still have the 11 badge.

    So on six test sites where Jetpack was already enabled, the upgrade was seamless. But the three sites where I freshly activated Jetpack I saw these problems.

    Is this a problem that others can reproduce? I want to be sure before I upgrade my network.


Viewing 13 replies - 1 through 13 (of 13 total)
  • One more thing, on the Jetpack admin page for the problem sites, the Debug bar has the following notice:

    NOTICE: wp-content/plugins/jetpack/jetpack.php:1807 - Undefined offset: 1

    This notice does not appear on the Jetpack admin page for the sites where Jetpack is working correctly.

    For the “11” badge:

    How did you install Jetpack?

    Did you ever have Jetpack 1.1.3 installed (but either not activated or not connected) on those sites prior to installing Jetpack 1.2?

    Ah ha: this is a multisite installation? There’s probably a bug, and I’ll look into it.

    To configure your sharing options, you should be able to do either:
    1. Admin → Jetpack, click “Configure” in the Sharing feature’s box.
    2. Admin → Settings → Sharing

    Do neither work for you?


    Because Jetpack was not yet appearing in the automatic updater (early adopter, I guess), I downloaded it from Then I manually replaced the “jetpack” folder in /wp-content/plugins.

    I already had Jetpack 1.1.3 installed and Network Activated. Three test sites were not connected to Jetpack on and still had the “Learn More” banner message.

    For the broken sites with the Debug message, the Sharing link is gone from the Admin → Settings menu, and the Configure button is gone from the Sharing feature’s box (for the working sites, the Sharing settings appeared as expected).

    If I try to trick it by going to the “options-general.php?page=sharing” link manually for one of the three test sites, I get the message, “You do not have sufficient permissions to access this page.”

    Thanks for the tip about the badge. I think we have that bug fixed. We’ll probably release it as part of a bug fix release next week. In the meantime, the badges and PHP notices are not harmful, though they are annoying.

    For the sharing configuration, when you go to Admin → Jetpack on a broken site, do you see any “Configure” buttons at all?

    Are the broken sites each connected to (each has to be connected individually)?

    Can you give me the URL of one of your broken sites?

    Yes, I see Configure buttons for Stats, Spelling and Grammar, Gravatar Hovercards, and Extra Sidebar Widgets — just like the working sites. Sharing is the only one with the missing configure button.

    Two test sites with the semi-functional Jetpack are:

    They are each connected to, authorized by user “wdsoit.” I have tried disconnecting and reconnecting to within each site as well.

    And I guess I should clarify something. The dev sites with the problem had already been created awhile ago; they had just not been connected to A few minutes ago, on the same network, I created a brand new site “foobar,” connected it to, and everything worked just fine.

    This is a really weird bug.

    My first suggestion is to delete the jetpack plugin directory completely, then redownload and install a fresh copy. Maybe something magical will happen.

    Failing that, here are some shot in the dark questions:

    1. Is anything in your WordPress, plugins, or jetpack directories installed under a symlink?
    2. Do you have any other copies of the Jetpack plugin lying around on your server?
    3. Do you know if you have APC or some other opcode cache running on your server?
    4. Do you have any output/object cache plugins active in WordPress (W3 Total Cache, WP Super Cache, …)?
    5. Do all of the sites under your multisite have the same domain (all are in “subdirectories”), or do some have different domains or subdomains?

    It was a really weird bug. Hopefully, it was an isolated one. I upgraded to Jetpack 1.2.1, and those two blogs still had a missing sharing button. Fortunately, they were just test sites that were of no consequence. I deleted them.

    BTW, shot in the dark questions: 1. No, 2. No, 3. No (APC turned off temporarily), 4. No, 5. all are subdirectories.

    As, I said, though, it was, hopefully, an isolated issue, but if it pops up again for someone else, at least you have a starting point.

    I deployed Jetpack 1.2.1 to our -qa environment, repeated some of the same testing that I had done on our dev environment, and the problem did not resurface.

    I feel confident deploying this to our production environment next week. Thanks for your help, mdawaffe.


    Thanks for all the feedback.

    Glad the bug’s gone (for the moment…). I hope it doesn’t come back, but if it does, let me know.


    I spoke too soon. I saw a couple of others in the forums that were having trouble with the Sharing feature, then I found a blog on my -qa system that did not yet have Jetpack connected to I connected the blog to, and the Sharing button was missing. I looked at the option_value for the option_name “jetpack_options” in the wp_#_options table for that blog (and then for a working blog).

    Site where sharing button is missing:

    SIte where sharing button appears:

    Well, that was interesting. Where is the version info? So I deleted the jetpack_activated row for the broken blog. (It was a throwaway site.) When I reloaded the Jetpack admin page for that blog, the Sharing button appeared. I looked in the database. The jetpack_activated row was recreated, and the jetpack_options row looked much closed to the working one:

    I repeated my “jetpack_activated” deletion test again with another blog and got the same result. No version info in jetpack_options initially, but version info was generated after I deleted and reloaded.

    So the only way that I can think of to try and recreate this:
    1. Have a WP 3.2.1 multisite network with Jetpack 1.1.3. (Mine uses subdirectories. PHP 5.3.3)
    2. Do not connect Jetpack to on a couple of blogs.
    3. Upgrade Jetpack to 1.2.1 (I did it in the file system, not the GUI, both on my dev and qa servers)
    4. Connect one of the test sites to to see if the Sharing configure button shows up.
    5. If Sharing is broken, check out the options table for that blog.

    You might have to copy my post into a text editor that soft wraps to see the code differences.

    The important takeaway was that this part (the version info) was gone initially:


    I tried those steps yesterday but was unable to reproduce the bug. Now when I try your steps, I see the bug, so clearly I was doing something wrong before.

    Thanks for the thorough explanation and for your patience. Now that I can reproduce the bug, I’ll be able to fix the problem.

    I have a potential fix for this bug, but it’s going to require a lot of retesting on our end before we can release it.

    In the meantime, your method is a viable (if annoying) workaround: delete the “jetpack_activated” option from the database.

    A slightly better workaround would be to add a “jetpack_do_activate” option to your blog’s database, with a value of “1”.

    Either works; both are annoying.

    We’ll have a real fix for this soon.

    Sounds good. I am just glad that I could be of some help with this issue. Version 1.2 added some amazing features to Jetpack, and I can’t wait to roll it out to our users.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: Jetpack by] Jetpack 1.2, 11 badge does not go away’ is closed to new replies.