Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » [Plugin: Jetpack by WordPress.com] Glitch in Jetpack

  • I cannot seem to connect to WordPress.com using Jetpack. Before even hitting the Connect button, I got the following error message:

    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: xml_rpc-32601
    Try connecting again.

    I try clicking connect again and again, but the same message continues to appear.

Viewing 12 replies - 16 through 27 (of 27 total)
  • I used the fix above and it worked! Thanks!

    atobias wrote:

    modify wp-content/plugins/jetpack/jetpack.php.
    On line 1290, change the current:
    if ( $jetpack->use_ssl[$method] ) {
    to the new:
    if ( false && $jetpack->use_ssl[$method] ) {

    I only deactivated Cloudflare ant it worked perfectly!
    Didn’t thought about it !
    Thanks

    Darn… no proxy servers, nothing blacklisted in .htaccess.

    Tried with all plugins inactive, and tried the above code

    I still has glitch….

    editing the jetpack works perfectly and I like it better anyway. open notepad copy your jetpack file from the plugin editor and find if ( $jetpack->use_ssl[$method] ) { then replace with if ( false && $jetpack->use_ssl[$method] ) { the then just paste the whole thing back into the editor and update

    I unistalled all plugins, except akismet. Did the editor thingy… and still glitch.

    Jetpack is broken for me as well. No .htaccess, no cache plugins, site is publicly available and the server can make SSL connections. The error I’m getting is…

    Your Jetpack has a glitch. Connecting this site with WordPress.com is not possible. This usually means your site is not publicly accessible (localhost).

    @kevitivity:

    Have you tried the latest version. If so, does your blog dashboard runs under https??

    Try to connect jetpack from your dashboard but with a normal (not secured) http

    There is currently a general issue on WordPress.com that is impacting Jetpack Stats and new Jetpack connections.

    Right now best bet is to follow @wordpressdotcom on twitter or @jetpack as we’ll keep you posted there.

    Well, I tried just about everything of the above, and nothing works ?
    I got this warning:
    Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host. There are no HTTP transports available which can complete the requested request.

    I contacted my ISP and he says that everything should work??

    I get the same error as johnyw:

    Jetpack could not contact WordPress.com: register_http_request_failed.

    Any solutions available?

    I’ve just been updating my sites, replacing WP Stats with Jetpack.

    From the sites that are on one of my Hostgator servers, all the .com sites connect perfectly. The .net and .info sites refuse to connect with the error:
    Your website needs to be publicly accessible to use Jetpack:
    Error Details: The Jetpack server was unable to communicate with your site [IXR -32300].

    I’ve disabled all caches and tried the php fix above, but to no avail. Any other suggestions?

    All resolved, thanks to Jetpack support at WordPress.com

    They found that there was intermittent public access to my sites and suggested I look at the DNS.

    There was a failure on one of the Nameservers on my hosting account which Hostgator resolved.

    All is now working as it should.

    If you see this ‘Your website needs to be publicly accessible to use Jetpack’ then check your DNS settings are working correctly by contacting your webhosting service.

Viewing 12 replies - 16 through 27 (of 27 total)
  • The topic ‘[Plugin: Jetpack by WordPress.com] Glitch in Jetpack’ is closed to new replies.