Support » Plugins and Hacks » Jetpack by WordPress.com » [Resolved] [Plugin: Jetpack by WordPress.com] Diagram in Stats not working since updating to WP3.4

[Resolved] [Plugin: Jetpack by WordPress.com] Diagram in Stats not working since updating to WP3.4

  • Hi there,
    I just updated my three wordpress installations to version 3.4

    Everything is fine, but the Jetpack stats are a bit confused.
    The diagramm (visitors per day, week, month) can’t be displayed.
    Summary table is ok. I even can see the actual data of today and yesterday.
    Only the diagram isn’t working anymore.

    Jetpack 1.3.4 is installed.

    Thanks in advance!



Viewing 15 replies - 1 through 15 (of 39 total)
  • I have the same problem, visitor numbers diagram not showing
    I too have Jetpack 1.3.4 and wordpress 3.4

    Glad it’s not just me. I’m also using WordPress 3.4 and Jetpack 1.3.4. Everything’s working fine except the stats graphs. Stats graphs are showing on the dashboard, just not in the actual stats section.

    The error I get is here:

    jQuery(document).ready( function($) {
    	function select2BlogStatFormat( blog ) {
    		var formatted = blog.text.replace( /([^(]+)/, '<b>$1</b>' );
    		return formatted;
    ===>	jQuery( '#statsblog' ).select2( {
    		formatResult: select2BlogStatFormat,
    		formatSelection: select2BlogStatFormat
    	} );
    } );
    > jQuery( '#statsblog' )
    > jQuery( '#statsblog' ).select2( {
    		formatResult: select2BlogStatFormat,
    		formatSelection: select2BlogStatFormat
    	} );
    TypeError: Object [object Object] has no method 'select2'

    Same with me too!! The circle for wait just never ends.



    Forum Moderator

    Have you tried:

    – deactivating all other plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.


    My jetpack plugin (1.3.4) is also not working, when it tries to display the diagram. It also did not work, when i had WP 3.3. But it first stopped working today. 🙁

    I tried:
    – deactivating all plugins but jetpack. Still not working.
    – updating to WP 3.4. Not working.

    Sadly without luck. Not so keen on updating/resetting all files via FTP or PhpAdmin. Think i’ll wait.

    And it’s not a browser issue. Tried it on IE9, Firefox and Chrome. Without luck.



    Forum Moderator

    Can I ask you all to indicate:
    – the host you’re using
    – the type of server (Windows or *nix)
    – browser(s) used
    – whether you have any browser add-ons

    It might help to track this problem down. In the meantime, I’ll flag it up as a possible issue.

    I’m not keen on messing with files, I don’t really know what I’m doing, so I’ll wait too

    My site too has started doing this with WP 3.4 and JP 1.3.4.

    The graph on the dashboard screen is appearing though – just an endless spinning progress wheel on the ‘site stats’ page….

    It’s very possible it’s just traffic 🙂

    Everyone and their brother are getting 3.4, updating themes, plugins, etc.

    Mine is the same graph on dashboard is OK but not on the stats page, never ending spinning progress wheel

    Plugin Contributor Tim Moore


    We are taking a look at this now. I’ll let you know when we have more information.

    Mine stats were working fine until I updated to 3.4, looks like Jetpack has a problem with the new update.

    Why Dont you guyzz checked its campatibility with this upcoming version of wordpress. So, carelessnessssssssss…….
    When i open my dashboard Jetpack sitestats is the first link i click and its not working now, u can imagine how bad i m feeling right now.
    Plzz guyzz solve this bugggg.

Viewing 15 replies - 1 through 15 (of 39 total)
  • The topic ‘[Resolved] [Plugin: Jetpack by WordPress.com] Diagram in Stats not working since updating to WP3.4’ is closed to new replies.
Skip to toolbar