Support » Plugin: Jetpack by WordPress.com » [Plugin: Jetpack by WordPress.com] Custom form not emailing content

  • Resolved tpope

    (@tpope)


    I setup a custom form on a page to help readers submit letters to the editor. I submitted to a few to see how it looked when I got the email, but it never came. I even logged out as myself and submitted one. I already chose the specific email it’s supposed to go to but I still haven’t gotten an email with the comments.

    http://wordpress.org/extend/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Author Beau Lebens

    (@beaulebens)

    Hi — we’ve made some changes to the Contact Form module in the 1.7 release that just came out today. Can you please upgrade, then try again and let us know if you still have troubles?

    I’m having the same problem on my own test site with both Jetpack and one called “Fast Secure Contact Form” so I don’t believe it’s just Jetpack that has the problem. I’d like to use Jetpack, only because I want to keep the number of plugins being used to a minimum.

    I’ve upgraded to the most recent version of Jetpack yesterday, but the problem persists.

    WordPress does send emails, registrations and password retrievals both work, so I know that the site can send email.

    I figure there is something I’ve not done in configuring this, or messed up at some point, but I can’t figure it out.

    Any suggestions would be helpful.

    Eric the Grey

    Quick update on this. I installed an Email Log plugin to track emails sent, and I can see what is going out. The To: field is blank.

    I’ve once again tested with resetting a user password, and the to: field shows both the end users email, as well as the admin account email. It seems to be that regardless of what I put in the to field for the contact form, they are not getting sent to a given address.

    You can see a screenshot (for now) at: http://test.tanzegier.com/

    Eric the Grey

    Plugin Author Beau Lebens

    (@beaulebens)

    Have you filled out the “to” field when you create your form?

    I’ve just done a test and it appears to be working as expected here.

    https://img.skitch.com/20120828-d6wn4tdacge4qxufb9t6d9ans.jpg

    In the image above you’ll see where you need to set the To address for when you create your form.

    I am having the same problem. My install of WP and my install of the plugin are both the newest version. I have my email address explicitly set in the form, and it’s still not sending the emails. I’m also not getting a notification on the administration panel when new feedback arrives. So if I don’t just happen to check the Feedback section, I won’t get the message. Could it be a problem in the way I have the plugin configured?

    Possibly relevant: I’ve recently (within the past few weeks) moved to a new host, and don’t have sendmail configured on my server. Does this plugin use the server’s mail program, or does it send it with PHP?

    I did fill out that part of the form. If you tried from my installation, nothing has come through.

    I’m beginning to think it’s in whatever hook the plugins are using to send the email with. Both the Jetpack plugin, as well as Contact Form 7 are failing to send, even though mail from Contact Form 7 actually has a To: entry. I’m still not getting anything in my administrator mailbox.

    Again, other emails are being sent, just not the comment forms.

    Eric the Grey

    WP3.4.1 + JP1.7

    I am having same issue. I am wondering if (at least in our case) it is possible that Google’s mail servers are detecting these messages as spam and blocking them entirely from reaching even the Spam folder of our email accounts?

    Here is the code I am using:
    [contact-form subject="Contact Form Submission" to="xxxx@xxxx.com"] [contact-field label="Name" type="name" required="true" /] [contact-field label="Email" type="email" required="true" /] [contact-field label="Website" type="url" /] [contact-field label="Comment" type="textarea" required="true" /] [/contact-form]

    OK, I’ve figured it out!

    I was putting my administrators email address in the form when I set it up, and when you open the form, the address was showing up in the “email address” box. I was changing this of course, to put in the “from” address, and the system was apparently replacing that with the “to” address. My host won’t let me send tmail from forms to an address not associated with the site.

    This is a bit of a problem because the workaround is to change the “email address” field to a text field. This won’t validate that the user is actually putting in an email address, which it should be doing (IMO).

    At this time, my form is working again, just not perfectly.

    Eric the Grey

    Eric, that fix didn’t work for me, but it looks like you may be using some slightly different contact form. I’m just using the standard Jetpack form.

    I’ve disabled all the other contact forms and only have a freshly installed version of Jetpack in use currently.

    Sorry if it doesn’t work. I would make sure that the email address you are using is the one associated with your host and domain. Some have restrictions on how email can be sent from your web sites.

    Unfortunately, that’s all I can think of.

    Eric the Grey

    Hi Eric,

    What exactly do you mean by host and domain? We use a shared host with multiple domains on the account. Also, we don’t host our email through the web host, but rather use GAFYD. I have never run into email restrictions using GAFYD before.

    Either way, I just tried and it doesn’t seem to work with the main host/domain account email.

    Are you saying that you think the issue is with our respective hosting accounts and not with Jetpack?

    Thanks

    Ok, for example, my hosting service (Dreamhost) requires me to have any email being sent from a form on my web page, be it from WordPress, or a static HTML form, to come from one of my domain’s email addresses (ei: some.name@tanzegier.com) and not, say a Gmail account.

    But anyway, It was a thought, and the solution worked for me even though it doesn’t seem perfect to me.

    Eric the Grey

    Either way I appreciate you sharing your solution. Hoping that the devs can figure this one out. It’s not a very good solution to have to go into the Admin panel to check to see if anyone has submitted the form.

    Well, it was my hope that I could help others find a solution. I’ve worked in tech support so long, it’s second nature now. 🙂

    Eric the Grey

    Plugin Author Beau Lebens

    (@beaulebens)

    @meanderingthemaze: are you by chance entering the same email address in both places? e.g. you’re sending to/from the same address? I’ve seen a lot of servers block that type of thing.

    Can you try some different email address combinations in the 2 places? Especially try addresses that don’t end up sending to each other (e.g. if you have an address that maps to/forwards to a GMail address, then don’t use that + the GMail address it forwards to).

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Plugin: Jetpack by WordPress.com] Custom form not emailing content’ is closed to new replies.