WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Jetpack by WordPress.com] Conflict with Jetpack and Post Publishing

[Plugin: Jetpack by WordPress.com] Conflict with Jetpack and Post Publishing

  • I recently had an issue with being able to publish a post. I could save a draft or preview the post but when I pressed the publish button nothing would happen.

    I then began to turn off my plugins one-by-one to see which plugin was the culprit. As it turns out, when I deactivated Jetpack I was able to publish the post.

    I’m not sure whether it’s the plugin itself or a module within JP but I was wondering if anyone else had experienced this issue.

    http://wordpress.org/extend/plugins/jetpack/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Beau Lebens

    @beaulebens

    Member

    Hi Marcus — are you still having this problem with Jetpack?

    Can you try disabling the Enhanced Distribution module, and also perhaps the Spelling and Grammar module to see if they are the ones causing it?

    Also — did you notice any javascript errors or anything when you tried to Publish?

    I am having the same issue. JetPack is the culprit after turning off all Plugins and turning them back on one-by-one. I deactivated the Enhanced Distrib module, but I do not see where to deactivate Spelling and Grammar. Can you advice?

    Thanks, in advance.

    Don

    Whoops – sorry! Found it… also, posting now works with Grammar turned off.

    I am having a very similar problem, with Jetpack active, the publish button disappeared from the post edit view. For posts already published, the update button is missing. To bypass this I have to save the draft and publish through the quick edit menu.

    Disabling the Enhanced Distribution module does not fix this.

    For Spelling and Grammar I don’t see a deactivation button, but I can only configure it, and as far as I can tell, I have no active proofreading checkboxes.

    So I am still stuck with the missing publish button. Disabling Jetpack fixes the conflict.

    Can anyone help?
    Thanks!

    spisana:

    you can disable Spelling & grammar by going to the Learn More button – this solved my similar problems.

    good luck

    Don

    dconnors:

    Thanks for pointing out where the disable button was… oops!

    I continued playing with disabling different modules and finally found the culprit: shortcode embeds.

    Disabling shortcode embeds fixed my issue, even when I re-enabled spelling and grammar and enhanced distribution.

    Thanks for pointing me towards the right direction!
    Simone

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: Jetpack by WordPress.com] Conflict with Jetpack and Post Publishing’ is closed to new replies.